4

I am writing a JACS communication Supporting Information in Latex using achemso package where the manuscript type set to suppinfo.

\documentclass[journal=jacsat,manuscript=suppinfo]{achemso}

I am then calling for the contents (sections and subsections) with:

\tableofcontents

As here in the simplified form

\documentclass[journal=jacsat,manuscript=suppinfo]{achemso}
\title{Title goes here}

\begin{document}

\tableofcontents

\section{Header 1}
\subsection{Header 1.1}
\subsection{Header 1.2}
\subsection{Header 1.3}
\subsection{Header 1.4}
\section{Header 3}
\section{Header 4}
\section{Header 5}
\section{Header 6}

\end{document}

But I get an empty contents section enter image description here

How can I fix that?

  • Do you compile your document twice? Welcome to TeX.SE! – Zarko May 9 '17 at 12:20
  • Yes I did multiple times but doesn't work.. Thanks! – Yigit Altay May 9 '17 at 12:21
  • unfortunately I'n not familiar with achemso document class. With article your MWE works as expected. Hopefully here are some users who will be able help you. – Zarko May 9 '17 at 12:38
  • indeed it is something related to the achemso package. I also tried with simple article class and it works... – Yigit Altay May 9 '17 at 12:42
1

The standard settings used unnumbered sections for supinfo: these are not written to the .toc file. You need to add

\SectionNumbersOn

before \begin{document} to reactivate them.

| improve this answer | |
  • it worked like a charm! Thanks a lot Joseph! – Yigit Altay May 9 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.