1

I've tried all stackexchange questions and now turn in desperation to asking myself:
I have a folder from Uni with tfm files, some map file.. etc. The installation says:

  1. Copy the file frutiger.tar.gz to the Library-folder in your home directory.
  2. Unzip the file.
  3. Open a shell and execute: sudo updmap —enable Map=~/Library/texmf/dvips/base/frutiger.map

Did that but now the compilation doesn't go through and I get a bunch of:

./section-introduction/introduction.tex:1: Font T1/pfr/m/n/72=pfrr8t  
> at 72.0pt  not loadable: Metric (TFM) file not found.  
> ./section-introduction/introduction.tex:2: Font  
> \T1/pfr/b/n/17.28=nullfont not

I've blindly tried the commands in this question.. no luck. Thanks for your help

12
  • Does this help? tex.stackexchange.com/questions/254996/…
    – JPi
    May 9 '17 at 19:49
  • @JPi this only tells me how to set fonts - am I wrong? The template already exists and works on my colleague's computer. The font is set with \fontfamily{pfr}
    – dv3
    May 9 '17 at 19:53
  • @JPi do you know any other place to ask this? kind of have to get this resolved :-/
    – dv3
    May 9 '17 at 22:14
  • This is the right place, I just don't own the font and don't know fonts well enough to be able to answer your question without being able to try.
    – JPi
    May 9 '17 at 22:48
  • 1
    @dv3 The point is to use getnonfreefonts-sys rather than getnonfreefonts, where applicable. In your case, that's not applicable. But you should use updmap-sys rather than updmap and install into TEXMFLOCAL rather than TEXMFHOME. You don't need to run mktexlsr if you installed into your personal tree (TEXMFHOME), but installing here is really not a good idea. Install into TEXMFLOCAL, run mktexlsr and then updmap-sys with the --enable line. (Better to change updmap.cfg, but that's more complicated, so probably easiest to stick to the --enable and just use the -sys.
    – cfr
    May 10 '17 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.