3

The footnote from inside the tabularx environment dose not get displayed when the hyperref package is loaded. The tabular environment on the other hand works like expected in both cases. Any suggestions on how to fix this?

\documentclass{article}
\usepackage{array,tabularx}
\usepackage{hyperref}   
\begin{document}
    \begin{minipage}{0.2\linewidth}
        \begin{tabularx}{\linewidth}{ X c  }
            A1\footnote{footnoteX} & B1  \\
            A2 & B2  \\ 
        \end{tabularx}
    \end{minipage}      

    \begin{minipage}{0.2\linewidth}
        \begin{tabular}{ c c  }
            A1\footnote{footnote} & B1  \\
            A2& B2  \\  
        \end{tabular}
    \end{minipage}      
\end{document}
2

You should use \footnotemark and \footnotetext here:

\documentclass{article}
\usepackage{array,tabularx}
\usepackage{hyperref}   
\begin{document}
    \begin{minipage}{0.2\linewidth}
        \begin{tabularx}{\linewidth}{ X c  }
            \renewcommand{\thefootnote}{\emph{\alph{footnote}}}
            A1\footnotemark & B1  \\
            A2 & B2  \\ 
        \end{tabularx}
        \footnotetext[1]{footnoteX}%sadly you have to specify the number in this case
    \end{minipage}      

    \begin{minipage}{0.2\linewidth}
        \begin{tabular}{ c c  }
            A1\footnote{footnote} & B1  \\
            A2& B2  \\  
        \end{tabular}
    \end{minipage}      
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.