0

Fresh new with LaTeX, I've a problem with moderncvtheme :

\url{http://machin.net/cours-­truc} 

give me

http://machin.net/cours-\discretionary{-}{}{}truc

in the final PDF.

Here's my code :

\documentclass[10pt,a4paper,roman]{moderncv}
\moderncvtheme[blue]{classic}
\usepackage[utf8]{inputenc}
\usepackage[scale=0.90]{geometry}
\nopagenumbers{}
\title{Conservateur des bibliothèques}
\firstname{Daniel}
\familyname{Bourrion}
\social[twitter][twitter.com/dbourrion]{dbourrion}
\usepackage{graphicx}
\begin{document}
\maketitle
\section{Parcours professionnel}
\cventry {2009}{La balade des bibs}{}{Master Pro Histoire et Document, spécialité Métiers des archives et des bibliothèques.
\url {http://fr.slideshare.net/dbourrion/cours-­m2­-histoire­-archives­-bibliothques­-30112009}}{}{}
Same result with : 
\href{http://fr.slideshare.net/dbourrion/cours-­m2­-histoire­-archives­-bibliothques­-30112009}{http://fr.slideshare.net/dbourrion/cours-­m2­-histoire­-archives­-bibliothques­-30112009}
\end{document}

Any idea ? Thanks. Best regards. D.

2
  • 1
    Welcome to LaTeX! Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – Moriambar
    May 13, 2017 at 7:32
  • Hi. Yep, please a look :
    – dbourrion
    May 13, 2017 at 11:20

1 Answer 1

1

Moderncv provides the \link[text]{actual link} and \httplink(same syntax) for displaying links. Those work fine for me, you should try and stick with them. Unfortunately I'm on mobile thus unable to provide an example

3
  • Hi. Thanks for the help but \httplink[httplink http://fr.slideshare.net/dbourrion/m2­-bibproangers2015­52928296]{fr.slideshare.net/dbourrion/m2­-bibproangers2015­52928296} comes out in my pdf like http://fr.slideshare.net/dbourrion/m2\discretionary {-}{}{}-bibproangers2015\discretionary {-}{}{}52928296 Too bad :(
    – dbourrion
    May 13, 2017 at 15:16
  • @dbourrion of course you shouldn't put the actual link in the optional argument of httplink
    – Moriambar
    May 14, 2017 at 18:28
  • 1
    Oh... got it - I was typing httplink[httplink text]{actual link}but the right way is httplink[text]{actual link} It works now, thanks
    – dbourrion
    May 15, 2017 at 6:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .