I have read a few posts about this issue and tried to follow the fixes in them, but yet to no avail. So I am using TexStudio and TexLive and running pdflatex compiler.

It seems to be a similar issue as this thread.

However following those answers and adding \epstopdfsetup{outdir=./} to solve path issues did not help.

I'll provide an isolated test code to highlight the issue.







The first picture works out fine. It just seems that the epstopdf doesnt succeed to generate the PDf from the eps. Any ideas why it might happen??

This produces the error message:

 Package pdftex.def Error: File `./image2-eps-converted-to.pdf' not found. ...cs[]{image2.eps}

and the following error log file:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016/W32TeX) (preloaded format=pdflatex 2017.2.15)  13 MAY 2017 15:53
entering extended mode
 restricted \write18 enabled.
 %&-line parsing enabled.
LaTeX2e <2017/01/01> patch level 1
Babel <3.9r> and hyphenation patterns for 83 language(s) loaded.
Document Class: paper 2008/05/30 1.0l LaTeX document class (wm).
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
Package: graphicx 2014/10/28 v1.0g Enhanced LaTeX Graphics (DPC,SPQR)

Package: keyval 2014/10/28 v1.15 key=value parser (DPC)
Package: graphics 2016/10/09 v1.0u Standard LaTeX Graphics (DPC,SPQR)

Package: trig 2016/01/03 v1.10 sin cos tan (DPC)
File: graphics.cfg 2016/06/04 v1.11 sample graphics configuration
Package graphics Info: Driver file: pdftex.def on input line 99.

File: pdftex.def 2017/01/12 v0.06k Graphics/color for pdfTeX

Package: infwarerr 2016/05/16 v1.4 Providing info/warning/error messages (HO)
Package: ltxcmds 2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
Package: epstopdf 2016/05/15 v2.6 Conversion with epstopdf on the fly (HO)

Package: epstopdf-base 2016/05/15 v2.6 Base part for package epstopdf

Package: grfext 2016/05/16 v1.2 Manage graphics extensions (HO)

Package: kvdefinekeys 2016/05/16 v1.4 Define keys (HO)
Package: kvoptions 2016/05/16 v3.12 Key value format for package options (HO)

Package: kvsetkeys 2016/05/16 v1.17 Key value parser (HO)

Package: etexcmds 2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)

Package: ifluatex 2016/05/16 v1.4 Provides the ifluatex switch (HO)
Package ifluatex Info: LuaTeX not detected.
Package etexcmds Info: Could not find \expanded.
(etexcmds)             That can mean that you are not using pdfTeX 1.50 or
(etexcmds)             that some package has redefined \expanded.
(etexcmds)             In the latter case, load this package earlier.
Package: pdftexcmds 2016/05/21 v0.22 Utility functions of pdfTeX for LuaTeX (HO

Package: ifpdf 2016/05/14 v3.1 Provides the ifpdf switch
Package pdftexcmds Info: LuaTeX not detected.
Package pdftexcmds Info: \pdf@primitive is available.
Package pdftexcmds Info: \pdf@ifprimitive is available.
Package pdftexcmds Info: \pdfdraftmode found.
Package epstopdf-base Info: Redefining graphics rule for `.eps' on input line 4
Package grfext Info: Graphics extension search list:
(grfext)             [.png,.pdf,.jpg,.mps,.jpeg,.jbig2,.jb2,.PNG,.PDF,.JPG,.JPE
(grfext)             \AppendGraphicsExtensions on input line 456.

File: epstopdf-sys.cfg 2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Liv
\openout1 = `texstudio_WE8212.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.

[Loading MPS to PDF converter (version 2006.09.02).]
<"C:/Users/XMAWAL/Google Drive/Master thesis - Mattias Wallin/Images/"hybrid_st
epper_motor_schematic.png, id=1, 507.39563pt x 494.59781pt>
File: "C:/Users/XMAWAL/Google Drive/Master thesis - Mattias Wallin/Images/"hybr
id_stepper_motor_schematic.png Graphic file (type png)

<use "C:/Users/XMAWAL/Google Drive/Master thesis - Mattias Wallin/Images/"hybri
Package pdftex.def Info: "C:/Users/XMAWAL/Google Drive/Master thesis - Mattias 
Wallin/Images/"hybrid_stepper_motor_schematic.png used on input line 13.
(pdftex.def)             Requested size: 172.5pt x 168.14592pt.
Package epstopdf Info: Source file: <"C:/Users/XMAWAL/Google Drive/Master thesi
s - Mattias Wallin/Images/"microstepping.eps>
(epstopdf)                    date: 2017-05-13 12:19:04
(epstopdf)                    size: 212900 bytes
(epstopdf)             Output file: <./"microstepping-eps-converted-to.pdf>
(epstopdf)             Command: <repstopdf --outfile=./"microstepping-eps-conve
rted-to.pdf "C:/Users/XMAWAL/Google Drive/Master thesis - Mattias Wallin/Images
(epstopdf)             \includegraphics on input line 20.
runsystem(repstopdf --outfile=./"microstepping-eps-converted-to.pdf "C:/Users/X
MAWAL/Google Drive/Master thesis - Mattias Wallin/Images/"microstepping.eps)...
quotation error in system command.

Package epstopdf Info: Result file: <./"microstepping-eps-converted-to.pdf>.

! Package pdftex.def Error: File `./microstepping-eps-converted-to.pdf' not fou

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.

l.20 ...cs[width=0.5\textwidth]{microstepping.eps}

Using draft setting for this image.
Try typing  <return>  to proceed.
If that doesn't work, type  X <return>  to quit.

[1{c:/texlive/2016/texmf-var/fonts/map/pdftex/updmap/pdftex.map} <c:/Users/XMAW
AL/Google Drive/Master thesis - Mattias Wallin/Images/hybrid_stepper_motor_sche
matic.png>] (./texstudio_WE8212.aux) ) 
Here is how much of TeX's memory you used:
 1637 strings out of 493013
 23366 string characters out of 6136993
 79835 words of memory out of 5000000
 5190 multiletter control sequences out of 15000+600000
 4718 words of font info for 18 fonts, out of 8000000 for 9000
 1141 hyphenation exceptions out of 8191
 42i,7n,23p,337b,230s stack positions out of 5000i,500n,10000p,200000b,80000s
Output written on texstudio_WE8212.pdf (1 page, 89925 bytes).
PDF statistics:
 27 PDF objects out of 1000 (max. 8388607)
 17 compressed objects within 1 object stream
 0 named destinations out of 1000 (max. 500000)
 6 words of extra memory for PDF output out of 10000 (max. 10000000)

2 Answers 2


The log file contains the following lines:

Package epstopdf Info: Result file: <./"microstepping-eps-converted-to.pdf>.

! Package pdftex.def Error: File `./microstepping-eps-converted-to.pdf' not found.

Note the quote present in the file that epstopdf creates (or tries to create, at least). This extra quote is caused by the quote in your \graphicspath.

If your path does not contain any spaces, the quotes aren't necessary and you can simply use \graphicspath{{C:/Users/XMAWAL/Example/Images/}}. If your path does contain spaces, the simplest solution would be to move the images to a folder not containing spaces. Making epstopdf work peacefully with space-containing paths is perhaps possible, but I don't know how.

  • This is correct! However a bit annoyingly, as the only reason I have the citation marks is because I have my directory in a Google Drive folder and the name for that ("Google Drive") path contains a space and is controlled by its .exe I can't change. So yes, easiest workaround is creating an extra folder for the images somewhere. However it will leave some extra work to keep the images synced etc. (for having access on two computers). Thanks for your help, I will accept this as correct in a while, if noone else does know how to make the eps package understand "cited" paths. May 14, 2017 at 9:36
  • You can try to make a symbolic link from a directory without spaces to a directory with spaces, and then reference the former in LaTeX. On Linux this is done with ln -s "path/with spaces" path/without/spaces and on Windows with mklink /D path/without/spaces "path/with spaces", both on the command line. Note the different order of the arguments.
    – cp.fe.cp
    May 14, 2017 at 12:27

I had a similar problem with eps to pdf conversion. The log shows the error message as "file not found". I figured that the issues were with the figure name. It has a blank space in the name (for instance bus voltage.eps). The problem was solved when I changed the figure name to busVoltage.eps by deleting the blank space.

The error also pops up if the figure path has blank space in it. It's better to avoid blank spaces with _.

I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .