1

My index entries get rejected. I compile, and then in TexStudio do Tools > Commands > MakeIndex

I thought I did everything according to the documentation.

I had no problems using makeidx.

\documentclass{article}
\usepackage{splitidx}

\makeindex
\newindex[Berechnen]{rech}
\newindex[Graph]{gra}


\begin{document}
    text
    \newpage
    text 1
    \sindex[rech]{lord}
    \newpage
    text2\sindex[rech]{shawty}
    \newpage
    text3\sindex[gra]{leftist}
    \printindex[rech]
    \newpage
    \printindex[gra]
\end{document}
  • I get Scanning input file buoch-gra.idx....done (1 entries accepted, 0 rejected). for the first index and Scanning input file buoch-rech.idx....done (2 entries accepted, 0 rejected). for the second one. – egreg May 13 '17 at 16:57
  • I get 'This is makeindex, version 2.15 [MiKTeX 2.9.6200] (kpathsea + Thai support). Scanning input file MWE.idx...done (0 entries accepted, 3 rejected). Nothing written in MWE.ind. Transcript written in MWE.ilg.' Does that provide further information? Seems ike only one .idx file is made ... – Buochserhorn May 13 '17 at 17:02
  • You have to run splitindex, not makeindex. – egreg May 13 '17 at 17:06
1

When you use splitidx, the correct sequence of commands is

pdflatex file
splitindex file
pdflatex file

The program splitindex will create the .idx files and then run makeindex over them.

  • How do I "run splitindex"? Windows user here :-) – Buochserhorn May 13 '17 at 17:14
  • @Buochserhorn Sorry for you. ;-). Define a new tool for TeXStudio that runs splitindex instead of makeindex. – egreg May 13 '17 at 17:19
  • I tried to do that, can see the splitindex package in the Miktex package manager, but still get: 'Process started: "C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/splitindex.exe" splitindex.exe: The script could not be found. splitindex.exe: Data: scriptEngine="perl", name="splitindex", path="scripts/splitindex/perl/splitindex.pl"' [I get the same error when I change the default index tool to splitindex, and makeindex and splitindex are in the same folder] – Buochserhorn May 13 '17 at 18:08
  • @Buochserhorn I think you need Perl, but I'm afraid I know nothing about Windows. – egreg May 13 '17 at 18:10
  • I installed that in the meantime thanks to this question, now only the script is missing. :-) – Buochserhorn May 13 '17 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.