2

I am using Texmaker 4.5 on Windows 10 and the built-in spell-checker stops working if I copy and paste a section into the document. It seems to work/not-work on a paragraph by paragraph basis. If I try to spell-check a non-working section I am told that no misspelled words were detected, even if I have complete gibberish in the paragraph.

The figure below shows the issue I am having, see how the three gibberish words above the citation are not marked as misspelled, while the words below are correctly tagged with a red line.

enter image description here

Additionally, it appears that if I use \cite{} in the section that was once copied into the document the spell checker works until I close the brackets. For example, here is a working spell-checkerenter image description here

and here is a unworking spell-checker. enter image description here

All I did was close the bracket and the spell checker stopped working.

I have checked this the same document on my laptop running texmaker 4.1 on a Linux platform and it works perfectly.

  • I cannot verify on windows machine, Makesure the path to .dic file in Spelling Dictionary is properly placed and the right language is chosen based on your preference. Go to File Menu of Texmaker --> Options-> Configure Texmaker-->Editor--> Spelling Dictionary. WARNING(you will loose your settings if you proceed in this way): on worst case scenario restart the texmaker Reset settings of Texmaker – texenthusiast May 16 '17 at 5:01
  • I did check that the dictionary is properly placed and I reset the setting of TexMaker. My next step is to reinstall the program, however, while working on the problem I downloaded TeXstudio. I have to say that I am very happy with this "interim" solution. – Austin Downey May 19 '17 at 6:58
  • I have a similar problem! It's probably a bug in the Linux version – Hooman Feb 4 '18 at 20:00
  • This may well be the same issue as tex.stackexchange.com/q/444349/35864, which will be resolved in the next version of TeXmaker. If you can consistently reproduce this weird behaviour I think it is fair to assume this is a bug that should have been reported to the developers. In cases like this there is often little that can be done on this site. Work-arounds often have disadvantages and the developers should know about this. – moewe Aug 3 '18 at 5:35
1

I am a beginner user of LaTex, so apologies if the answer is not professional, but it solved my problem.

I had the same issue and tried to update to the latest version (5.0.2) of Texmaker but no luck. I was using {natbib} package and the command \cite{..}.

However, when I changed the citation package from \usepackage{natbib} to \usepackage{apacite} and only use \citeA{...} or citeNP{...} commands the spelling check starts to work as normal. Even with the {apacite} package the issue still appears if I use the command \cite{..}.

I hope this might encourage expert users to give a detailed answer!

  • Welcome to TeX.SX! A workaround is better than nothing! – egreg Feb 7 '18 at 14:53
0

A simple workaround to fix the issue is as follows:

I am using TexMaker 5.0.2 with Bibtex and IEEEtran style. In my .tex file, what I realized is that sentences/paragraphs before \cite are not spellchecked. See:

spellcheck is off

What I do is simply press Enter (new line) before the \cite command and continue the sentence. You should do it for each and every \cite command.

spellcheck is up and running

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.