3

I am using pdfTeX v.3.14159265-2.6-1.40.17 on Arch linux. This is my relevant preamble.

    \documentclass[a4paper,twoside,11pt]{report}
    \usepackage[utf8]{inputenc}
    \usepackage{titlesec,hyperref,cite,graphicx}

All PDFs I compile have bitmapped Type3 fonts. I need vector fonts. I can add \usepackage[T1]{fontenc} without success. I have updated the fontmap.

According to the bottom of the log I see the fonts used, for example:

home/dmt/.texlive/texmf-var/fonts/pk/ljfour/public/cm/cmr10.657pk

and

usr/share/texmf-dist/fonts/pk/ljfour/public/cm/dpi600/cmr12.pk

Should I install cm-super? Why is it not included in my TeX Live installation? I am uncertain and have been unsuccessful in the process of manually installing it.

3
  • 2
    Welcome to TeX.SE! Can you include more details from the log (e.g. change to a minimal example, for which you can include the full log file), mention how you installed your TeX distribution, etc.? – ShreevatsaR May 16 '17 at 5:33
  • 1
    How did you update the fontmap? The Type 1 cmr fonts (e.g. cmr10.pfb) are part of texlive-core if you are using the TeX Live of arch linux. So they should be there. Maybe you should remove (or rename) /home/dmt/.texlive to come back to the distribution settings. Note: Don't use updmap for updating the fontmaps, use sudo updmap-sys. – Schweinebacke May 16 '17 at 6:01
  • Can you report the path of the loaded pdftex.map, that you find in the log file? – egreg May 16 '17 at 6:07
2

Update: Problem resolved by reinstalling texlive-core.

THank you for answering (: ! Here is a minimal example.

Doc:

\documentclass[11pt]{article}
\title{\textbf{Bon Giorno}}
\author{DMT}
\begin{document}
\maketitle
\section{Pixels}
Low DPI
\end{document}

Log:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016/Arch
Linux) (preloaded format=pdflatex)  \write18 enabled. entering
extended mode (/home/dmt/.cache/gummi/gummi_L0UD0Y LaTeX2e
<2016/03/31> patch level 3 Babel <3.9r> and hyphenation patterns for
83 language(s) loaded.
(/usr/share/texmf-dist/tex/latex/base/article.cls Document Class:
article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size11.clo)) No file
gummi_L0UD0Y.aux.
[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]
(/home/dmt/.cache/gummi/gummi_L0UD0Y.aux) )
</home/dmt/.texlive/texmf-var/fonts /pk/ljfour/public/cm/cmr10.657pk>
</home/dmt/.texlive/texmf-var/fonts/pk/ljfour /public/cm/cmbx12.720pk>
</usr/share/texmf-dist/fonts/pk/ljfour/public/cm/dpi60 0/cmr12.pk>
</home/dmt/.texlive/texmf-var/fonts/pk/ljfour/public/cm/cmbx12.864p k>
Output written on /home/dmt/.cache/gummi/gummi_L0UD0Y.pdf (1 page,
11008 bytes) . Transcript written on
/home/dmt/.cache/gummi/gummi_L0UD0Y.log.

PDF:

dmt@dmt ~ $pdffonts "Desktop/minimal.pdf"
name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
[none]                               Type 3            Custom           yes no  no       4  0
[none]                               Type 3            Custom           yes no  no       5  0
[none]                               Type 3            Custom           yes no  no       6  0
[none]                               Type 3            Custom           yes no  no       7  0

I have renamed /home/dmt/.texlive without success. My problem persisted so I reinstalled the texlive-core package and now the cmr fonts are back in place.

Sorry for not trying that earlier. Thank you for the help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.