1

I am trying to reproduce this MWE, but I keep getting

Package pgfkeys Error: I do not know the key '/pgfplots/table/copy/column from table' and I am going to ignore it. Perhaps you misspelled it.

seems like this very same code works for some others but for me not. I am using Mac computer and compile the .tex file with Texmaker 4.5, anyone knows what is going on??

\documentclass{article}
\usepackage{pgfplotstable}

\begin{document}
\pgfplotstableread{h1_error.log}\dataA    
\pgfplotstableread{l2_error.log}\dataB

\pgfplotstablecreatecol[copy column from table={\dataB}{[index]0}] {par1} {\dataA}
\pgfplotstablecreatecol[copy column from table={\dataB}{[index]1}] {par2} {\dataA}

\pgfplotstabletypeset{\dataA}
\end{document}

where h1_error.log is

#N       H1 error
40  0.231438
#N       H1 error
40  -nan
#N       H1 error
40  0.231438
#N       H1 error
5   1.32218
#N       H1 error
5   1.60331

and l2_error.log is

#N       L2 error
40  0.00624957
#N       L2 error
40  0.00809222
#N       L2 error
40  0.00624957
#N       L2 error
5   0.246561
#N       L2 error
5   0.307461

closed as unclear what you're asking by Bobyandbob, Stefan Pinnow, user121799, Mensch, Phelype Oleinik May 29 '18 at 17:09

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Your MWE perfectly works for me, too. To check the different versions of package you use, with respect to others, put \listfiles at the beginning of your .tex file and you'll see the package versions on the log, see here: tex.stackexchange.com/questions/97924/…, for example. – CarLaTeX Dec 30 '17 at 16:23

Browse other questions tagged or ask your own question.