6

When using long section titles and the para option from footmisc, the footnotes are pushed off the edge of the page. E.g.

\documentclass{article}
\usepackage{lipsum}
\usepackage[para]{footmisc}
\begin{document}
    \section{This is a very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very long section title.}
        This is some text.\footnote{\lipsum[1-6]}
        \lipsum
\end{document}

Remove the para option to see the difference. How can I prevent the footnote from extending below the text boundaries?

2
  • 1
    As the documentation of footmisc explains, the para option is intended for short footnotes. You can clearly see that paragraphs in the footnote are not respected. With that option, footnotes are never split across pages.
    – egreg
    Dec 4, 2011 at 0:42
  • In my situation, the footnotes vary in length (5 to 20 words) and are high in number. I use the para option so that space is conserved as much as possible.
    – Village
    Dec 4, 2011 at 1:14

1 Answer 1

5

Run-in (paragraph) typesetting of footnotes in (La)TeX is tricky. An introduction to the problems faced is section 9 of the documentation of the manyfoot package. With regard to the algorithm of footmisc, its para option needs to "mess about with the output routine" (footmisc documentation, p. 12). Page 13 of the footmisc manual states:

We make a box out of the paragraph of footnotes, and then stuff the contents of the box into that which is going to be \shipped out.

Although I'm not familiar enough with LaTeX's output routine to be sure, I suspect that the "box" referred to simply can't be broken across pages.

Solution: Replace footmisc with the bigfoot package which features the most advanced algorithm for run-in footnotes.

\documentclass{article}
\usepackage{lipsum}
\usepackage{bigfoot}
\DeclareNewFootnote[para]{default}
\begin{document}
    \section{This is a very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very long section title.}
        This\footnote{Yes,} is\footnote{it is} some\footnote{indeed.} text.\footnote{\lipsum[1-6]}
        \lipsum
\end{document}

enter image description here

2
  • Why is the bigfoot package placing the fourth footnote on a new line? Is there a way to have it begin on the same line?
    – Village
    Dec 4, 2011 at 1:23
  • It seems that bigfoots algorithm tends to place long footnotes on a new line. I don't know how to change this.
    – lockstep
    Dec 4, 2011 at 1:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .