1

I need to use the SBL biblatex style but also need to modify it to move punctuation outside quotes, for example in the titles of book chapters. This post nearly gives me the solution: Slightly custom SBL to use single quotes instead of double quotes

The problem is that I use Polyglossia (for Hebrew mainly, but also for Greek), and Babel and Polyglossia don't seem to be compatible.

Here is what I am trying to get working:

My paper.bib:

@collection{smith_tap_2013,
location = {Nottingham},
title = {Essays on Changing Taps},
shorttitle = {Taps},
publisher = {House},
editor = {Smith, John G.},
date = {2013-11-15}
}

@incollection{shead_psalter_2013,
location = {Nottingham},
title = {Modern Taps},
shorttitle = {Modern},
pages = {23--45},
booktitle = {Essays on Changing Taps},
publisher = {House},
author = {Johnson, James},
editor = {Smith, John G.},
date = {2013-11-15}
}

My paper.tex:

%!TEX TS-program = xelatex
% !TEX encoding = UTF-8 Unicode

\documentclass[12pt,a4paper,oneside]{article}

\usepackage{fontspec}

% Below: packages for \textgreek and \texthebrew
\usepackage{polyglossia} 
\setdefaultlanguage[variant=british]{english} 
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont[Script=Hebrew]{SBL Hebrew}
\newcommand{\largeHeb}[1]{\large\texthebrew{#1}\normalsize}
\setotherlanguage{greek}
\newfontfamily\greekfont[Script=Greek]{SBL Greek}
\newcommand{\largeGk}[1]{\large\textgreek{#1}\normalsize}
\renewcommand\SepMark[1]{\def\@SepMark{#1}}\SepMark{.} 

\usepackage[style=british]{csquotes} % recommended by biblatex

\usepackage[style=sbl,backend=biber,date=year]{biblatex}

\addbibresource{paper.bib}

\begin{document}

Test1 \\
\cite{smith_tap_2013}

Test2 \\
\cite{smith_modern_2013}

In Greek man is \textgreek{ἄνθρωπος},
but in Hebrew man is \texthebrew{אָדָם}, which is different of course!

\printbibliography

\end{document}

Example Output

1

biblatex isn't able to detect language variants with polyglossia.

Add this line after usepckage{biblatex}:

\DeclareLanguageMapping{english}{sbl-english}

or

\DeclareLanguageMapping{english}{sbl-british}

In biblatex, the second uses ordinals for dates, I think.

By default biblatex-sbl prefers American language settings by including a line like this:

\DeclareLanguageMapping{english}{sbl-american}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.