2

I have two bib files and one latex file in a report style. I need one bibliography after my first part and the other bibliography at the end. Even though i got it somewhat correctly, the second bib files don't show the citations in the texts and instead shows like this: [?]. please help me fix this. I need to use bibtex compulsorily. Please help me. Thank you. My report outline looks like this:

\documentclass[12pt]{report}
\usepackage[margin=70pt]{geometry}
\usepackage{cite}
\usepackage{url}
\usepackage{etoolbox}
\apptocmd{\thebibliography}{\raggedright}{}{}
\title{aanfghn}
\author{Av}
\date{22 May 2017}

\begin{document}

\maketitle
\section{literature review}
some content here\cite{ref1}.
\bibliography{mybib1}
\bibliographystyle{plain}
\newpage
\section{Review of literature}
some content here[?].
\bibliography{mybib2}
\bibliographystyle{plain}

The first part cites the reference on pdf but the second part doesn't.

3

You can use the multibib package:

\documentclass{article}
\usepackage{multibib}
\newcites{first}{First Chapter Literature}
\newcites{second}{Second Chapter Literature}
\begin{document}
\nocitefirst{*}
\bibliographystylefirst{plain}
\bibliographyfirst{xampl}

\nocitesecond{*}
\bibliographystylesecond{plain}
\bibliographysecond{test}


\end{document}

You will then have to run bibtex first and bibtex second, e.g on a command line (my editor winedt does it automatically).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.