0

As also mentioned elsewhere, the garamondx has been marked as obsolete in one of the last MikTeX updates.

As suggested in various questions (here, or here) and also on the garamondx README, I tried to get back garamondx using the getnonfreefonts script, following the instructions found here.

However, when running texlua.exe ./install-getnonfreefonts the script fails with the error (I'm using Windows 10):

./install-getnonfreefonts:890: attempt to concatenate global 'texdir' (a nil value)

The lines in the script around L890 are

kpse.set_program_name('texlua')
texdir=kpse.var_value('SELFAUTOPARENT')
bindir=kpse.var_value('SELFAUTODIR')
exedir=kpse.var_value('SELFAUTOLOC')
texmflocal=kpse.var_value('TEXMFLOCAL')

if isdir(texdir .. '/texmf') then
  texmf_dir='/texmf'
else
  texmf_dir='/texmf-dist'
end

with L890 being the line starting with if isdir(...).

However, I don't know enough about lua to be able to diagnose what is causing this problem. How can this be solved?

marked as duplicate by Phelype Oleinik, glS, Bobyandbob, user36296, Community Jun 22 '18 at 14:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Does it even support miktex? Only texlive is mentioned on its website. – daleif May 22 '17 at 10:05
  • @daleif I actually just assumed it did for some reason, but now that you say it you're probably right, MikTex is not mentioned anywhere on the page. I guess I'll have to use one of the other methods listed on the garamondx README page for MikTeX then (which fail to work for other reasons, but that is a different story). Thanks anyway – glS May 22 '17 at 10:09
  • at the end I solved the problem as explained in this other question – glS Jun 24 '17 at 16:34
  • 2
    I'm voting to close this question as off-topic because the OP solved the problem by himself. – Phelype Oleinik Jun 22 '18 at 13:00
  • @PhelypeOleinik fair (though I don't see the close button on my own post?) – glS Jun 22 '18 at 13:09

Browse other questions tagged or ask your own question.