3

Referring to Garamondx does not work anymore in MiKTeX ...

I'm a beginner in latex, and I'd like to include this package, because I used it last year and now I can't TT.TT, but I don't understand what are they saying, could someone give me clear instructions? for dummies, please. I'm a windows' 10 user. Thank you a lot.

8
  • @HenriMenke Is that for MiKTeX too?
    – Ana
    Commented May 22, 2017 at 21:29
  • No it isn't. Close vote retracted. Commented May 22, 2017 at 21:38
  • Welcome to TeX SX! Did you install garamondx in a local TeXMF tree?
    – Bernard
    Commented May 22, 2017 at 23:07
  • @Bernard I don't know why garamondx is obsolete now :C On the other hand, I'm a beginner in latex, I use overleaf and there \usepackage[garamond]{mathdesign} worked while garamondx don't, but I wanted to install MiKTeX and Texmaker in my computer, because there's an image restriction in overleaf. Nevertheless, the \usepackage[garamond]{mathdesign} don't work, and appear errors like "citation ... undefined"... The point is, I don't know about installing packages in MiKTeX, even more, fonts packages.
    – Ana
    Commented May 23, 2017 at 1:36

2 Answers 2

7

For Garamondx, it is rather easy, as there exists a ready-to-install .zip file. Here are the details:

  • Go to this page on CTAN and download garamondx.tds.zip.
  • If you have a Local TeXMF directory, unzip the contents of this file in this directory.
  • If you don't, create one, say C:\LocalTeXMF, and validate it as TeX root directory via MiKTeX Settings (Admin), Roots tab, like this (it's my personal configuration, which uses another partition):

enter image description here]1

  • Refresh the FNDB with MiKTeX Settings (Admin), General tab.
  • You need a updmap.cfg file, which is a plain text file, in which you write these lines: #Garamondx Map zgm.map

This file is used to add the Garamondx font files to the database of type1 fonts.

If it does not exist, create it and place it in LocalTeXMF\miktex\config.

  • Last step: to update the databases (psfonts.map and its siblings), run from the command line, as administrator: updmap --verbose (the ‘verbose’ switch is used to display what happens).

That's all: from now on, the font can be used in TeX documents.

Urw-Garamond

For urw-garamond, it is a little more complex, because there is no ready-to-install .zip file. You can downloadgaramond.zip from this page,unzip it in some directory , and copy the different files in the relevant subdirectories in LocalTeXMF, according to the T.D.S. (‘TeX Directory Structure’) and refresh the FNDB.

Finally, add to updmap.cfg the lines

#urw-garamond Map ugm.map

and run updmap from the command line.

3
  • 1
    I have never seen a font installation so clearly explained. Thanks! Commented May 23, 2017 at 13:30
  • Thank you Bernard, I had to install both and now it works! Easy to understand <3 :3
    – Ana
    Commented May 23, 2017 at 18:53
  • @Bernard I found this especially helpful, thank you writing this out so clearly! Commented Sep 14, 2017 at 17:45
1

You can install getnonfreefonts first (refer to http://www.tug.org/fonts/getnonfreefonts/) and run getnonfreefonts --sys garamond from a command line. Then, include \usepackage[garamond]{mathdesign} in the head of your tex file. I've tried it and it works!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .