I'm using TexShop (2.43 on 10.6) to manage LaTeX, but have the following error:

! LaTeX Error: File 'uarial.sty' not found.

I tried to use the approach in this question with


But apparently, uarial.sty isn't already installed. It is definitely a CTAN package, and I don't see any relevant packages in TeX Live's download list. What package should I look for in the download list, as the downloads are taking forever? Or is there some other way I should be using?

I attempted to install the non-free fonts. To do so, I've done this:

  1. Downloaded install-getnonfreefonts from the link @MarcoDaniel provided.
  2. created the following script to avoid having to edit my own path:


#script to run the font installer once it's in the directory export PATH=/usr/local/texlive/2010/bin/x86_64-darwin:$PATH

exec texlua ~/Downloads/install-getnonfreefonts

  1. Ran that script as sudo, got this output:
    Detected System: x86_64-darwin
    Detected Installation: /usr/local/texlive/2010
    Installing texmf/scripts/getnonfreefonts/getnonfreefonts.pl ...          [done]
    Installing texmf/doc/man/man1/getnonfreefonts.1 ...                      [done]
    Installing texmf/doc/man/man1/getnonfreefonts-sys.1 ...                  [done]
    Installing texmf/doc/man/man1/getnonfreefonts.man1.pdf ...               [done]
    Installing texmf/doc/man/man1/getnonfreefonts-sys.man1.pdf ...           [done]
    md5sum: cdc91dd4b6bea936a013a16836421a0b getnonfreefonts.pl ...            [ok]
    md5sum: f850d910dd96ee27cecdb3772047d247 getnonfreefonts.1 ...             [ok]
    md5sum: fb2b0f7699db8e627d4e26b730e94928 getnonfreefonts-sys.1 ...         [ok]
    md5sum: 415b51f7c80a4abe8d0a667a04c9d525 getnonfreefonts.man1.pdf ...      [ok]
    Fixing File Permissions ...                                              [done]
    Creating symlinks in 'bin/universal-darwin' ...                          [done]
    Creating symlinks in 'bin/x86_64-darwin' ...                             [done]
    texhash: Updating /usr/local/texlive/2010/texmf/ls-R... 
    texhash: Done.
  1. Restarted TeXShip
  2. Rebuilt the file, no joy.

The font can be easily installed via the script getnonfreefonts. It is available at tug.org:

TUG getnonfreefonts

EDIT: I tried the installation of getnonfreefonts on my Mac. In the follwoing explaniation I will try to explain my steps. First I have the following machine:

  • iMac 27"
  • Installed updated MacTeX 2011

Now the steps.

  1. I downloaded the installation script.
  2. Open the terminal and go to the folder Download

    cd Download

  3. Run the installation:

    sudo texlua install-getnonfreefonts

  4. The installation finished and the scipts with their execute files getnonefreefonts and getnonfreefonts-sys are now located at


  5. Now you can run the script

    sudo getnonfreefonts-sys -a

| improve this answer | |
  • Does this require that '/usr/local/texlive/2010/bin/x86_64-darwin ' be on the path? I've been avoiding modifying my path, as path pollution tends to make my life heinous. – mmr Dec 4 '11 at 21:07
  • This did not work. See the edits on my question. – mmr Dec 4 '11 at 21:59
  • @mmr: Please see my updated answer. – Marco Daniel Dec 5 '11 at 18:23
  • With current getnonfreefonts you need getnonfreefonts --sys -a instead of getnonfreefonts-sys -a! – Schweinebacke Nov 15 '17 at 7:43

If you can't use the getnonfreefonts script for some reason, you'll need to copy the relevant files yourself. I suggest you install them in your LOCALTEXMF directory tree. You'll need to have root or sudo privileges.

  • Download arial.zip from http://www.ctan.org/tex-archive/fonts/urw/arial/ to /usr/local/texlive/texmf-local. (Update, 2011/11/012: this zip file used to be called "ua1.zip", but at some point the file name appears to have been changed to "arial.zip".)

  • Uncompress the zip file. Various files will be copied into sub- and subsub-directories below the doc, dvips, fonts, and tex directories (including uarial.sty to tex/latex/ua1 and ua1.map to fonts/map/dvips/ua1).

  • Run sudo -H mktexlsr.

  • Run the command sudo -H updmap-sys --enable Map=ua1.map. (Update, 2012/11/02: The map file is still called "ua1.map" even though the name of the zip file has changed to arial.zip -- see above.)

  • Run sudo -H mktexlsr again.

Happy TeXing!

| improve this answer | |
  • This approach yields the error, @Mico: !pdfTeX error: /usr/texbin/pdflatex (file ua1b8a.pfb): cannot open Type 1 font file for reading. I had to run sudo ~/Downloads/updmap-sys.sh --enable Map=ua1.map --syncwithtrees, because there were some other files missing. Is my installation just hosed at this point? – mmr Dec 4 '11 at 22:53
  • At this point, I honestly can't tell. There's a separate issue: your TeX distribution is mildly obsolete. Have you considered installing MacTeX 2011? – Mico Dec 5 '11 at 2:27
  • @mmr pdflatex complains that it can't open ua1b8a.pfb. So did you install the fonts (they are in the same folder as ua1.zip and should go to fonts/type1/arial)? – Ulrike Fischer Dec 5 '11 at 8:38
  • @Mico-- I thought I had the most recent non-Lion build. I'll check out the new hotness... although this is due today at 5, so workarounds will be made instead, I think. – mmr Dec 5 '11 at 16:26
  • 1
    @TeXnewbie -- I would appear that the file that used to be called "ua1.zip" is now called "arial.zip". When you click on the "download zip file" link, you'll get "arial.zip". From a quick inspection of its contents, it looks like it has the same contents as the old "ua1.zip" file had. – Mico Nov 2 '12 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.