2

I am trying to get two videos to auto play at the same time using media9. Just putting two videos on the screen with autoplay on yields a delay in one video, causing them to be out of sync. Does anyone know how to sync them?

MWE with video

MWE Code:

\documentclass{beamer}
\usetheme{default}
\usepackage[utf8]{inputenc}

\usepackage{media9}

%%%%%%%%%%%%%%%%%% Macros to embed vids %%%%%%%%%%%%%%%%%%%

% inputs: source, width, height
\newcommand{\embedvid}[3]{
    \includemedia[
    width=#2,
    height=#3,
    keepaspectratio,
    activate=pageopen,
    passcontext,
    addresource=#1,
    flashvars={
        source=#1
        &loop=true
        &autoPlay=true
        &autoRewind=true
    }
    ]{}{VPlayer.swf}
}

\begin{document}

\begin{frame}{some frame}
    hi
\end{frame}

\begin{frame}{the videos}
    \embedvid{vid.mp4}{.53\paperheight}{0.3\paperheight}
    \embedvid{vid.mp4}{.53\paperheight}{0.3\paperheight}
\end{frame}

\end{document}

I am viewing in Adobe Acrobat Reader DC Version 2017.009.20044 on a Surface Pro 3, i7

  • I am afraid there isn't much to be done about this, because the viewer loads the FlashPlayer instances, the VPlayer apps and the video files sequentially. Each player starts the video playback as soon as it is ready without any knowledge about other players on the page. – AlexG May 24 '17 at 9:17
  • Bummer. Is there any sort of media button that can autofire on page opening or some delay after page opening? I know I have seen other posts that synchronize video by having the user activate a media button. Otherwise I guess I will just have to put the videos together externally. – Michael Sobrepera May 24 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.