1

I have written a paper with bibliography in IEEEtran style. Everything was compiled and generated properly. Now I have been asked to convert the references to APA style. I have added pacakge and bibstyle apacite.sty. Now I am unable to compile it. Undefined references messages are popping-up. My latex file looks like this:

    documentclass[conference]{IEEEtran}

    \ifCLASSINFOpdf
       \usepackage[pdftex]{graphicx}
 \DeclareGraphicsExtensions{.pdf,.jpeg,.png}
 \else
 \usepackage[dvips]{graphicx}
\DeclareGraphicsExtensions{.eps}
\fi

\usepackage{fixltx2e}

\ifCLASSOPTIONcompsoc
  \usepackage[caption=false,font=normalsize,labelfont=sf,textfont=sf]{subfig}
\else
  \usepackage[caption=false,font=footnotesize]{subfig}
\fi

\usepackage{txfonts}
\usepackage{multirow}
%\usepackage{apacite}


\providecommand{\e}[1]{\ensuremath{\times 10^{#1}}}

\begin{document}
 blah blah blah

 \bibliographystyle{IEEEtran/bibtex/IEEEtran}
 %\bibliographystyle{apacite}
\bibliography{bibfile}

 \end{document}

Latex messages are:

This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
entering extended mode
(./ije.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax,         dumylang, nohyphenation, loaded.
(./IEEEtran.cls
Document Class: IEEEtran 2014/09/17 V1.8a by Michael Shell
-- See the "IEEEtran_HOWTO" manual for usage information.
 -- http://www.michaelshell.org/tex/ieeetran/
 (/usr/share/texmf-texlive/tex/latex/psnfss/ot1ptm.fd)
  -- Using 8.5in x 11in (letter) paper.
 -- Using DVI output.
 -- This is a 10 point document.
 ) (/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
 (/usr/share/texmf-texlive/tex/latex/graphics/keyval.sty)
 (/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
 (/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
  (/etc/texmf/tex/latex/config/graphics.cfg)
  (/usr/share/texmf-texlive/tex/latex/graphics/dvips.def)))
  (/usr/share/texmf-texlive/tex/latex/base/fixltx2e.sty)
  (/usr/share/texmf-texlive/tex/latex/subfig/subfig.sty (./caption3.sty)) 
 (/usr/share/texmf-texlive/tex/latex/txfonts/txfonts.sty)
 (/usr/share/texmf-texlive/tex/latex/multirow/multirow.sty)        (./apacite.sty)
 (./ije.aux) (/usr/share/texmf-texlive/tex/latex/txfonts/omltxmi.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/omstxsy.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/omxtxex.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/utxexa.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/ot1txr.fd)
 -- Lines per column: 56 (exact).


 (/usr/share/texmf-texlive/tex/latex/txfonts/utxmia.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/utxsya.fd)
 (/usr/share/texmf-texlive/tex/latex/txfonts/utxsyb.fd)
  (/usr/share/texmf-texlive/tex/latex/txfonts/utxsyc.fd)


 LaTeX Warning: Reference `leakage' on page 1 undefined on input line 69.

 <gatelength.eps> <dynamic.eps> <leakage.eps>

  LaTeX Warning: Citation `chandrakasan1992low' undefined on input line      93.

 [1]

      LaTeX Warning: Citation `lee2004gate' undefined on input line 102.


    LaTeX Warning: Reference `igate' on page 2 undefined on input line 102.

    <igate.eps>
 ! Illegal parameter number in definition of \reserved@a.
  <to be read again> 
               }
 l.108 ...an nmos transistor \cite{choi2001impact}}
  ?

I have put all the apacite files in the common folder. Please help.

1
  • 2
    Welcome to TeX.SE. In your code, the instructions \usepackage{apacite} and \bibliographystyle{apacite} are both commented out, and the instruction \bibliographystyle{IEEEtran/bibtex/IEEEtran} has not been commented out (yet). How do you expect this to work?
    – Mico
    May 24, 2017 at 12:46

1 Answer 1

0

probably a bit late, but for future people looking for solutions, this fixed it for me:

One has to call the package hyperref: Fixing JAIR style

One has to set the option ‘draft’: \pdfendlink ended up in different nesting level than \pdfstartlink

This code in the preamble did the trick:

\usepackage[draft]{hyperref}
\hypersetup{%
    bookmarks=false,    % show bookmarks bar?
    pdftitle={TeX and friends hackers manual},    % title
    pdfauthor={Yiannis Lazarides},                     % author
    pdfsubject={TeX and LaTeX},                        % subject of the document
    pdfkeywords={TeX, LaTeX, graphics, images}, % list of keywords
    colorlinks=true,       % false: boxed links; true: colored links
    linkcolor=blue,       % color of internal links
    citecolor=black,       % color of links to bibliography
    filecolor=black,        % color of file links
    urlcolor=purple,        % color of external links
    linktoc=page            % only page is linked
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .