4

I wanted to use verbatim with beamer document class, but I noticed that all the tabs are replaced by ^^I.

A solution has been given to this problem Tabs in output file written by xelatex and pdflatex are different

But to solution requires that -8bit is added on the command line of xelatex. If I try to do that, I get the following error in xelatex.log:

2017-05-24 14:26:10,919+0200 INFO  xelatex - starting with command line: xelatex -8bit document.tex
2017-05-24 14:26:10,927+0200 FATAL xelatex - The command line options could not be processed.
2017-05-24 14:26:10,927+0200 FATAL xelatex - Info: optionError="unknown option"
2017-05-24 14:26:10,927+0200 FATAL xelatex - Source: Libraries\MiKTeX\TeXAndFriends\webapp.cpp
2017-05-24 14:26:10,927+0200 FATAL xelatex - Line: 339

So where did -8bit go and is there an alternative?

  • 3
    Welcome to TeX.SX! The -8bit option is valid for the TeX Live implementation of XeTeX; why this isn't accepted by MiKTeX is beyond my understanding. – egreg May 24 '17 at 13:03
5

XeTeX 3.14159265-2.6-0.99992 (MiKTeX 2.9) uses option --enable-8bit-chars instead of -8bit.

  • I use version Version 3.14159265-2.6-0.99998 (MiKTeX 2.9.6300 64-bit), which is slightly newer, and --enable-8bit-chars still don't work with xelatex, but does work with pdflatex – Michiel Fortuin Aug 8 '17 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.