2

I'm creating a list in 2 columns. I used the following code

\begin{multicols}{2}
    \begin{enumerate}[font=\bfseries,noitemsep]
        \item Cianotoxina(s) (\textit{Cyanotoxins(s)})
        \item Cilindrospermopsina(s) (\textit{Cylindrospermopsin(s)})
        \item Microcistina(s) (\textit{Microcystin(s)})
        \item Biodegradação (\textit{Biodegradation})
        \item Degradação (\textit{Degradation})
        \item Lago Paranoá (\textit{Paranoá Lake})
        \item Microbiota (\textit{Microbiota})
        \item Microbiota Bacteriana (\textit{Bacterial Microbiota})
    \end{enumerate}
\end{multicols}

In the 2nd item I'm getting a problem

enter image description here

How can I let LaTeX makes an automatical linebreak in lists with long words like this?

EDIT:

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[brazil]{babel}
\usepackage{multicol}
\usepackage{multirow}
\usepackage{enumitem}
\usepackage[none]{hyphenat}
\begin{document}
    \begin{multicols}{2}
        \begin{enumerate}[font=\bfseries,noitemsep]
            \item Cianotoxina(s) (\textit{Cyanotoxins(s)})
            \item Cilindrospermopsina(s) (\textit{Cylindrospermopsin(s)})
            \item Microcistina(s) (\textit{Microcystin(s)})
            \item Biodegradação (\textit{Biodegradation})
            \item Degradação (\textit{Degradation})
            \item Lago Paranoá (\textit{Paranoá Lake})
            \item Microbiota (\textit{Microbiota})
            \item Microbiota Bacteriana (\textit{Bacterial Microbiota})
        \end{enumerate}
    \end{multicols}
\end{document}

I'd like to have in item 2 something like:

  1. Cilindrospermopsina(s)

(Cylindrospermopsin(s))

  1. ...
  2. ...

EDIT 2: I did it manually

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[brazil]{babel}
\usepackage{multicol}
\usepackage{multirow}
\usepackage{enumitem}
\usepackage[none]{hyphenat}
\begin{document}
\begin{multicols}{2}
    \begin{enumerate}[font=\bfseries,noitemsep]
        \item Cianotoxina(s) (\textit{Cyanotoxins(s)})
        \item Cilindrospermopsina(s) \\(\textit{Cylindrospermopsin(s)})
        \item Microcistina(s) (\textit{Microcystin(s)})
        \item Biodegradação (\textit{Biodegradation})
        \item Degradação (\textit{Degradation})
        \item Lago Paranoá (\textit{Paranoá Lake})
        \item Microbiota (\textit{Microbiota})
        \item Microbiota Bacteriana (\textit{Bacterial Microbiota})
    \end{enumerate}
\end{multicols}
\end{document}

enter image description here

There's a way to do it automatically?

4
  • Please tell us which document class you use, which font size you employ, and which packages are loaded in the preamble. Please also tell us which language settings, if any, were chosen. Finally, at which points should the long word "Cylindrospermopsin" be breakable? I would guess "Cylindro-spermo-psin", but I'm not a specialist in your field...
    – Mico
    May 26, 2017 at 5:05
  • 1
    In fact, please put your code fragment into a minimal compilable document that shows the problem. If I paste your code into article class, the second line hyphenates (with or without babel). So you need to show exactly what you are doing to get the result you show.
    – Alan Munn
    May 26, 2017 at 5:07
  • Thanks for editing your posting and providing some additional information. Quick question: What do you think is achieved by \usepackage[none]{hyphenat}?
    – Mico
    May 26, 2017 at 5:16
  • @Mico avoid hyphenation. Actually, I want a newline with whole word. I don't want to break in syllables May 26, 2017 at 5:19

1 Answer 1

2

Be default, the contents of a multicols environment are typeset in fully-justified mode; it would appear that this is not what you want in your example. I therefore suggest you provide a \raggedright directive immediately after \begin{multicols}{2} (and before \begin{enumerate}...).

A code snippet:

\begin{document}
    \begin{multicols}{2}
    \raggedright % <--- new
        \begin{enumerate}[font=\bfseries,noitemsep]
            \item Cianotoxina(s) \dots

A full MWE:

enter image description here

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[brazil]{babel}
\usepackage{multicol,enumitem,geometry}
\usepackage[none]{hyphenat}
\begin{document}
    \begin{multicols}{2}
    \raggedright
        \begin{enumerate}[font=\bfseries,noitemsep]
            \item Cianotoxina(s) 
                  (\textit{Cyanotoxins(s)})
            \item Cilindrospermopsina(s) 
                  (\textit{Cylindrospermopsin(s)})
            \item Microcistina(s) 
                  (\textit{Microcystin(s)})
            \item Biodegradação (\textit{Biodegradation})
            \item Degradação (\textit{Degradation})
            \item Lago Paranoá (\textit{Paranoá Lake})
            \item Microbiota (\textit{Microbiota})
            \item Microbiota Bacteriana 
                  (\textit{Bacterial Microbiota})
        \end{enumerate}
    \end{multicols}
\end{document}
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .