11

The following MWE:

\documentclass{article}
\usepackage{polynom}

\begin{document}
$\polylongdiv{x^3+1}{x^2+3}$
\end{document}

produces the erroneous output

enter image description here

Note that the horizontal rule does not extend to the end of the dividend, and that the last step of the division is not performed.

Note that if the dividend is either x^3+x^2+x+1 or x^3+x^2+1 the package produces the complete remainder on the bottom line, while if it is x^3+x+1 or x^3+1, it does not. Mysterious, at least to me.

Is this package still maintained, or does anyone know a workaround?

4
  • Look in the manual, there you can find an email address for the package maintainer, so you can write and tell him about it. May 27, 2017 at 8:13
  • See the answer here: tex.stackexchange.com/a/8835/117534
    – Troy
    May 27, 2017 at 13:44
  • @TorbjørnT. The email address of the maintainer is not in the documentation. I've written the only person with that name I could find, but have heard nothing back. It looks as though I could implement the changes in the linked article above, but of course a fix to the package would be preferable.
    – rogerl
    May 28, 2017 at 17:46
  • Oh, right, I see. Sorry about that. May 28, 2017 at 18:04

1 Answer 1

5

This is indeed a bug. I found the maintainer through the magic of the Web and sent him this thread and the one referenced in Troy's comment above. He implemented that change; while it fixes the issue described here, he said it "breaks other functionality of the package". Therefore he will not be putting the change into CTAN.

So if you are interested in just a local change to fix this problem and are willing to examine your output carefully, the fix at https://tex.stackexchange.com/a/8835/117534 may do the trick; otherwise you're on your own at least for the moment...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .