4

Using lualatex, LuaTeX, Version 0.95.0 (the most recent version available for my distribution, ArchLinux), the following minimal example never finishes compiling on my machine. It simply stalls at some point, driving my CPU to 100%, so that I have to kill it. Using xelatex is a workaround. Is this possibly fixed in more recent versions of lualatex?

\documentclass{tikzposter}

\usepackage{unicode-math}

\begin{document}

\maketitle

\end{document}

\endinput
  • 2
    it runs without error for me with tl2017 (although not very interesting result) – David Carlisle May 27 '17 at 22:42
  • I can confirm this behaviour with TL 2016. However, it is more probable that this used to be an issue with unicode-math rather than with LuaTeX. – Henri Menke May 28 '17 at 3:35
3

This is the same bug as in How can I change math font with \setmathfont inside a group?

The problem is that tikzposter wraps the whole document in a group which is done in the hooks \AtBeginDocument and \AtEndDocument. Unfortunately, if you do not select a font in the preamble unicode-math will try to set the font to Latin Modern Roman when encountering \begin{document} which is in a group which makes it hang.

Workaround: Explicitly select the fonts in the preamble.

\documentclass{tikzposter}

\usepackage{unicode-math}
\setmainfont{Latin Modern Roman}
\setsansfont{Latin Modern Sans}
\setmonofont{Latin Modern Mono}
\setmathfont{Latin Modern Math}

\begin{document}

\maketitle

\end{document}
  • I did find the question you linked, but based on the answers/comments there didn't see the connection to my problem. Thank you for pointing that out! – mSSM May 28 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.