0

I have following strange problem. When I try to install any of the L3 packages (like l3packages, l3build, etc.) within the package manager I get:

The operation could not be completed because the following file failed verification:
C:\Miktex Package Repository\l3packages.tar.lzma

I think the files are not corrupted because I tried installing it on another computer and it worked. I also tried using different repositories. Latex output is just:

Fehler: running 'texi2dvi' on 'FILE.tex' failed LaTeX errors: ! LaTeX Error: File `xparse.sty' not found.

Does anybody know what's going on here? All other packages can be installed as far as I can tell. However, for other packages I also get a weird message, even though they are successfully installed.

The operation failed for some reason.

C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\initexmf.exe

I have no idea why this happening, I would be grateful for some insight.

  • Have you tried updating MikTeX and then rerunning the installation process? – TeXnician May 29 '17 at 7:18
  • Thanks for the reply. I can't update that easily as I am behind a company firewall which blocks on the fly installation from the Internet -> have to install each package manually. I am going to reinstall miktex tomorrow and see if this helps, extremely annoying... – user134791 May 29 '17 at 12:42
1

I had the same problem and looked into the log. It said that this command had failed:

C:\Program Files\MiKTeX 2.9\miktex\bin\x64>initexmf.exe --mklinks --mkmaps

I opened a command prompt in administrator mode and executed it and now pdflatex is working for me. I first tried to execute that in a non-administrator window and it failed because of permissions. So I am pretty sure this is the right solution.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.