2

I am using a Mac operating system and am not a sophisticated programmer. I am trying to run code that uses the line \usetikzlibrary{calc} but I keep getting the error "I can't find file pgflibrarytikzcalc.code.tex". I am using TeXShop and have an up to date copy. How can I obtain and install this library? I need detailed instructions because I have been unable to figure this out using other posts.

  • 2
    Note that the editor (TeXShop in this case) has nothing to do with you TeX distribution. It merely provides an interface, so it could be that your distribution is out-of-date. If you could post a minimal working example (MWE) that reproduces your problem, including \listfiles before \documentclass and post whatever's in your .log after ***File List*** (near the end of the .log file), we could examine it. – Werner Dec 5 '11 at 21:32
  • 3
    What is your version of MacTeX ? And your version of pgf-tikz? – Alain Matthes Dec 5 '11 at 21:32
  • Echoing Altermundus. This sounds like you have an outdated MacTeX. – qubyte Dec 6 '11 at 1:16
5

From the pgf/TikZ ChangeLog file:

2008-01-26 Till Tantau

  • Modified calc library. Working on documentation.
  • Added calc library and ($...$) notation for coordinates.

So you need a version of pgf/TikZ which is of this date or newer. If your version is older, you need to update it. MacTeX, which is built on TeX Live, provides the TeX Live Manager for it. Start the manager GUI, or type in a terminal window:

sudo tlmgr update pgf

to update pgf/TikZ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.