1

I have been dealing with this problem some days. Maybe you can help me? When running pdflatex I get this error:

! Argument of \UTFviii@three@octets has an extra }.
<inserted text>
\par
l.15
I've run across a `}' that doesn't seem to match anything.
For example, `\def\a#1{...}' and `\a}' would produce
this error. If you simply proceed now, the `\par' that
I've just inserted will cause me to report a runaway
argument that might be the root of the problem. But if
your `}' was spurious, just type `2' and it will go away.
Runaway argument?

Minimal Working Example

\documentclass[12pt,twoside]{report}
\usepackage[spanish]{babel}
\usepackage[utf8]{inputenc}
\usepackage{fancyhdr}
\pagestyle{fancy}
% no recuerdo para que era fancy
\usepackage{csquotes} 
\usepackage[backend=biber]{biblatex}
\addbibresource{bibtex.bib}

\begin{document}
\cite{klamt1993cosmo} \cite{quantum-continuum-tomasi2005}  \cite{tomasi-PCM1981}.
\printbibliography

\end{document}

The bib file i am using is:

% This file was created with JabRef 2.10.
% Encoding: UTF-8

@Article{klamt1993cosmo,
  Title                    = {COSMO: a new approach to dielectric screening in solvents with explicit expressions for the screening energy and its gradient},
  Author                   = {Klamt, Andreas and Sch{\"u}{\"u}rmann, GJGJ},
  Journal                  = {Journal of the Chemical Society, Perkin Transactions 2},
  Year                     = {1993},
  Number                   = {5},
  Pages                    = {799--805},

  __markedentry            = {},
  Publisher                = {Royal Society of Chemistry}
}

@Article{tomasi-PCM1981,
  Title                    = {Electrostatic interaction of a solute with a continuum. A direct utilizaion of AB initio molecular potentials for the prevision of solvent effects},
  Author                   = {Miertu{\v{s}}, S and Scrocco, E and Tomasi, J},
  Journal                  = {Chemical Physics},
  Year                     = {1981},
  Number                   = {1},
  Pages                    = {117--129},
  Volume                   = {55},

  Publisher                = {Elsevier}
}

@Article{quantum-continuum-tomasi2005,
  Title                    = {Quantum mechanical continuum solvation models},
  Author                   = {Tomasi, Jacopo and Mennucci, Benedetta and Cammi, Roberto},
  Journal                  = {Chemical reviews},
  Year                     = {2005},
  Number                   = {8},
  Pages                    = {2999--3094},
  Volume                   = {105},

  Publisher                = {ACS Publications}
}

I can not change this file, any change I make jabRef return them in this way again.

Only for it helps, I have download all packages (texlive, biber 1.9, texmaker) from promt, and I am using Debian.

When I remove \printbibliography errors are gone (but I need to print it)

Any idea of what is going on?

EDIT i do not know if it is an answer but changing to biblatex it works.

  • Works fine for me, but with your old biber installation... Maybe you should install a "vanilla" TeX Live that's up to date. – TeXnician May 30 '17 at 5:51
  • @TeXnician ok. Can install it from promt? And, is there any other change i should do? – HernanProust May 30 '17 at 5:54
  • @TeXnician Is it not the same if i have installed texlive?Sorry if i am wrong, i am starting with the programme and i get this error – HernanProust May 30 '17 at 5:58
  • 1
    biber 1.9 is very, very old. In TeX Live 2016 and TeX Live 2017 pretest we have currently biber 2.7. Last version in TeX Live 2015 was biber 2.4. AFAIK biber 1.9 is from TeX Live 2014. As I cannot reproduce the problem with TeX Live 2016 or TeX Live 2017 pretest but only with TeX Live 2014, I would recommend to update. – Schweinebacke May 30 '17 at 6:21
  • try to run biber with biber --output-safechars <file> – user2478 May 30 '17 at 7:53
3

Your example does work using current versions of biber and biblatex.

The problem with the outdated biber biblatex combination is, the

  Author                   = {Klamt, Andreas and Sch{\"u}{\"u}rmann, GJGJ},

line. Using a real UTF8 encoded file does work:

\listfiles
\begin{filecontents*}{\jobname.bib}
% This file was created with JabRef 3.6.
% Encoding: UTF-8

@Article{klamt1993cosmo,
  Title                    = {COSMO: a new approach to dielectric screening in solvents with explicit expressions for the screening energy and its gradient},
  Author                   = {Klamt, Andreas and Schüürmann, GJGJ},
  Journal                  = {Journal of the Chemical Society, Perkin Transactions 2},
  Year                     = {1993},
  Number                   = {5},
  Pages                    = {799--805},
  __markedentry            = {},
  Publisher                = {Royal Society of Chemistry}
}
\end{filecontents*}

\documentclass[12pt,twoside]{report}
\usepackage[spanish]{babel}
\usepackage[utf8]{inputenc}
\usepackage{csquotes} 
\usepackage[backend=biber]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\cite{klamt1993cosmo}.
\printbibliography

\end{document}

with

 *File List*
  report.cls    2014/09/29 v1.4h Standard LaTeX document class
  size12.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
   babel.sty    2014/09/25 3.9l The Babel package
 spanish.ldf
inputenc.sty    2014/04/30 v1.2b Input encoding file
    utf8.def    2014/09/29 v1.1m UTF-8 support for inputenc
   t1enc.dfu    2014/09/29 v1.1m UTF-8 support for inputenc
  ot1enc.dfu    2014/09/29 v1.1m UTF-8 support for inputenc
  omsenc.dfu    2014/09/29 v1.1m UTF-8 support for inputenc
csquotes.sty    2011/10/22 v5.1d context-sensitive quotations
etoolbox.sty    2015/03/19 v2.1d e-TeX tools for LaTeX (JAW)
    etex.sty    2015/03/02 v2.1 eTeX basic definition package (PEB,DPC)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
csquotes.def    2011/10/22 v5.1d csquotes generic definitions
csquotes.cfg    
biblatex.sty    2014/06/25 v2.9a programmable bibliographies (PK/JW/AB)
biblatex2.sty    2014/06/25 v2.9a programmable bibliographies (biber) (PK/JW/AB)
kvoptions.sty    2011/06/30 v3.11 Key value format for package options (HO)
 ltxcmds.sty    2011/11/09 v1.22 LaTeX kernel commands for general use (HO)
kvsetkeys.sty    2012/04/25 v1.16 Key value parser (HO)
infwarerr.sty    2010/04/08 v1.3 Providing info/warning/error messages (HO)
etexcmds.sty    2011/02/16 v1.5 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO)
  logreq.sty    2010/08/04 v1.0 xml request logger
  logreq.def    2010/08/04 v1.0 logreq spec v1.0
  ifthen.sty    2014/09/29 v1.1c Standard LaTeX ifthen package (DPC)
     url.sty    2013/09/16  ver 3.4  Verb mode for urls, etc.
  blx-dm.def
biblatex-dm.cfg
blx-compat.def    2014/06/25 v2.9a biblatex compatibility (PK/JW/AB)
biblatex.def    
standard.bbx    2014/06/25 v2.9a biblatex bibliography style (PK/JW/AB)
 numeric.bbx    2014/06/25 v2.9a biblatex bibliography style (PK/JW/AB)
 numeric.cbx    2014/06/25 v2.9a biblatex citation style (PK/JW/AB)
biblatex.cfg    
 spanish.lbx    2014/06/25 v2.9a biblatex localization (PK/JW/AB)
    test.bbl
   ulasy.fd    1998/08/17 v2.2e LaTeX symbol font definitions
 ***********

and biber 1.9 does result in

Bibliography

without any error.

So I would recommend to either update your TeX distribution (at least biber and biblatex) or to change your database to use real UTF8 encoded special characters instead of things like {\"u}.

BTW:

\listfiles
\begin{filecontents*}{\jobname.bib}
@Article{klamt1993cosmo,
  Title                    = {COSMO: a new approach to dielectric screening in solvents with explicit expressions for the screening energy and its gradient},
  Author                   = {Klamt, Andreas and Sch\"u\"urmann, GJGJ},
  Journal                  = {Journal of the Chemical Society, Perkin Transactions 2},
  Year                     = {1993},
  Number                   = {5},
  Pages                    = {799--805},
  __markedentry            = {},
  Publisher                = {Royal Society of Chemistry}
}
\end{filecontents*}

\documentclass[12pt,twoside]{report}
\usepackage[spanish]{babel}
\usepackage[utf8]{inputenc}
\usepackage{csquotes} 
\usepackage[backend=biber,bibencoding=ascii]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\cite{klamt1993cosmo}.
\printbibliography

\end{document}

would also work.

  • I have things encoded like that an it does not work – HernanProust May 30 '17 at 9:19
  • @HernanProust: Maybe you've forgotten to remove some auxiliary files or you have not fixed the coding of all special characters. I've tested the examples with the given versions of biber and biblatex. Both work. Have you really tested my examples? – Schweinebacke May 30 '17 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.