1

I'm trying to change my page margins, but for some reason Lyx won't let me do it. I've gone to Document -> Settings -> Page Margins, but changing values there seems to have no effect at all. I'm using the "Article (Standard Class)" document class and a default page layout. Any help would be much appreciated as I have a deadline this afternoon.

1

without margin

I guess that really you have not problems with margins but you have not understood the basic idea behind LyX. Instead of follow the model WYSYWYG (What You See Is What You Get) of almost all word processors, the LyX model is WYSYWYM (What You See Is What You Mean).

In Document > Settings > Page Margins you will the margins of the PDF output, not what you see in the LyX screen, as well as you will not see either the hyphenated words, paragraphs skips, etc. The Lyx window show you the content structure with a basic text format (section titles in a large bold font) and little more. LyX (LaTeX really) worries about where things go on the page, not you. To allow text justification the output could have some extra interword spacing, but you are not allowed to do this with SpaceSpaceSpace. You can specify some paragraph skips in document settings, but you are not allow to add black lines with EnterEnterEnter and you will not see paragraphs skips and page breaks except in the outputs of Document > View or File > Export.

Then, if your problem is not see the final margin, there are not solution to your problem. You must adapt to LyX, or use a payware WYSYWYG LaTeX editor as Bakoma. or not use LateX at all.

If your problem is that (independently of the results) is unpleasant write with a minimal margin in the LyX windows, there are some solution, but only for the full screen mode (F11 to toggle):

Export > Preferences... > Editing > Contol > Check Limit text width > Set number of pixels

Result using 500 pixels in my screen:

with margins

But in the final PDF the margins will not change at all.

  • Yes, I know Lyx is WYSYWYM. However, the margins don't change when I produce a pdf preview of the document. It fixed itself when I copied and pasted everything into a new blank document though. – InquisitiveInquirer Jun 1 '17 at 4:17
  • 1
    @InquisitiveInquirer I see, It is the problem of guessing without a MWE... If you are still curious about what happened, reduce the original file with the problem to a MWE (one paragraph without user specified LaTeX preamble is enough), check that the problem is still present and post the LaTeX source. If the problem disappear while cleaning something in order to make the MWE, congratulations, you have found the problem. – Fran Jun 1 '17 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.