2

Hello after compiling the code found below using WinEdt 10 PDFLaTeX, I ran arara from the accessories menu but got an error I didn't get any directives in 'animated1.tex' , so didn't do anything...

Can you tell me how to use arara for this code:

%arara: animate: {density: 160, delay: 8}
\documentclass[tikz]{standalone}
\usepackage{amsmath,amssymb}
\usepackage{pgfplots}

\pgfplotsset{compat=1.13}
\usepgfplotslibrary{fillbetween}

\begin{document}
\foreach \mainangle [count=\xx, evaluate=\mainangle as \mark using (\mainangle/45)] in {0,5,...,355,360}{
\begin{tikzpicture}
\begin{axis}[
    set layers,
    x=1.5cm,y=1.5cm,
    xmin=-3.7, xmax=8.2,
    ymin=-1.5, ymax=1.5,
    axis lines=center,
    axis on top,
    xtick={2,4,6,8},
    ytick={-1,-.5,.5,1},
    xticklabels={$90^{\circ} (\pi/2)$, $180^{\circ} (\pi)$, $270^{\circ} (3\pi/2)$,$360^{\circ} (2\pi)$},
    xticklabel style={font=\tiny},
    yticklabels={-1,-0.5,0.5,1},
    ylabel={$\sin(x)$}, y label style={anchor=west},
    xlabel={$x$}, x label style={anchor=south},
]
\pgfonlayer{pre main}
\addplot [fill=white] coordinates {(-4,-2) (8.5,-2) (8.5,2) (-4,2)} \closedcycle;
\endpgfonlayer

\path[name path=xaxis] (axis cs:-4,0) -- (axis cs:8,0);
\coordinate (O) at (axis cs:0,0);

% plot and circle
\addplot [samples=100,domain=0:8, name path=myplot](\x,{3 * sin(\x*45)/pi});
\draw[name path=circle] (axis cs:-2.5,0) circle (1.5cm);

% fill in circle and plot
\draw[black,fill=blue!40] (axis cs:-2.5,0) -- (axis cs:-1.5,0) arc (0:\mainangle:1.5cm) coordinate (cc) -- cycle;
\path[name path=mark] (axis cs:\mark,-1) -- (axis cs:\mark,1);
% small circles
\draw (cc) circle (3pt);

\path[name intersections={of=mark and myplot,by=cp}];
\draw (cp) circle (3pt);
\draw (cc) -- (cp) -- (cp|-O);

\ifnum\mainangle<5
\else
\addplot[blue!30] fill between[of=xaxis and myplot, soft clip={domain=-1:\mark}];
\fi
\end{axis}
\end{tikzpicture}}
\end{document} 
  • 1
    This help? – Fran May 31 '17 at 6:27
  • 1
    You wrote %arara: but arara needs a space: % arara: – Arzigoglu May 31 '17 at 11:36
  • Looks like arara is being called, but you haven't specified your directive correctly – cmhughes May 31 '17 at 12:16
  • @cmhughes Can you tell me how to specify the directive? Thanks! – Joe May 31 '17 at 13:43
  • See Arzigoglu's comment – cmhughes May 31 '17 at 13:59
4

You forgot a space in the arara directive.

The right one should be:

% arara: animate: {density: 160, delay: 8}

Remember that this directive works if you have the animate.yaml rule as in this cmhughes's answer and ImageMagick installed (during install time remember to check the option "Install legacy utilities (e.g. convert)" otherwise convert.exe won't be installed).

Also you need to have compiled the source file into .pdf otherwise the conversion cannot start.

So I suggest you to add the rule

% arara: pdflatex

before the above one and let arara do the whole work for you.

EDIT

Supposing that you're going to place your animate.yaml in the folder C:\arara\myrules, the contents of araraconfig.yaml must be

!config
paths:
- C:\arara\myrules

The file araraconfig.yaml has to be placed in the folder C:\Users\<Username>, where <Username> is your Windows User Account name.

  • 1
    @Joe You first have to create an araraconfig.yaml file in C:\Users\Username with your custom paths as described in the preface of section 6 ("Configuration file") and subsection 6.1 ("Search paths") of the arara manual. Then put your animate.yaml in one of the paths listed there. – Arzigoglu Jun 1 '17 at 5:08
  • 1
    @Joe Does the edit in the answer helps? – Arzigoglu Jun 2 '17 at 4:54
  • 1
    @Joe Which version of arara are you using? Note that both MiKTeX and TeX Live come with arara installed. – Arzigoglu Jun 2 '17 at 5:22
  • 1
    @Joe Do you have Java installed? arara works only if you have Java on your machine. – Arzigoglu Jun 2 '17 at 5:29
  • 1
    @Joe Isn't it that your custom arara installation is interferring with the arara which comes with your TeX distribution? Try uninstalling your custom arara. WinEdt will find the one of the distro. – Arzigoglu Jun 2 '17 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.