1

I don't know what to do, I'm new at LaTeX and I want to use it for my thesis. Everything with my code is fine, when I compile without the glossaries package. When I compile my LaTeX code I get this error messages:

! Use of \\lstinline doesn't match its definition.
\kernel@ifnextchar ...rved@a {#2}\def \reserved@b 
                                                  {#3}\futurelet \@let@token...
l.79 ...ndle{#2} \FP@gen@exp@handle{#3} div #4#5}}

If you say, e.g., `\def\a1{...}', then you must always
put `1' after `\a', since control sequence names are
made up of letters only. The macro here has not been
followed by the required stuff, so I'm ignoring it.

! Undefined control sequence.
\lsthk@PreSet ... \fi \fi \let \lst@advancenumber 
                                                  \z@ 
l.79 ...ndle{#2} \FP@gen@exp@handle{#3} div #4#5}}

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

)
! Incomplete \iffalse; all text was ignored after line 79.
<inserted text> 
                \fi 
l.25 

The file ended while I was skipping conditional text.
This kind of error happens when you say `\if...' and forget
the matching `\fi'. I've inserted a `\fi'; this might work.

)
! Incomplete \iffalse; all text was ignored after line 25.
<inserted text> 
                \fi 
l.45 \RequirePackage
                    {datatool-base}
The file ended while I was skipping conditional text.
This kind of error happens when you say `\if...' and forget
the matching `\fi'. I've inserted a `\fi'; this might work.

)


! Undefined control sequence.
l.2569   \dtlifnumgt{\@dtl@numi}{\@dtl@numii
                                            }%
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Illegal parameter number in definition of \FP@gen@mul@splitted.
<to be read again> 
                   3
l.2571     #3
             %
You meant to type ## instead of #, right?
Or maybe a } was forgotten somewhere earlier, and things
are all screwed up? I'm going to assume that you meant ##.

! Illegal parameter number in definition of \FP@gen@mul@splitted.
<to be read again> 
                   4
l.2574     #4
             %
You meant to type ## instead of #, right?
Or maybe a } was forgotten somewhere earlier, and things
are all screwed up? I'm going to assume that you meant ##.

! Undefined control sequence.
l.2577 \newcommand*{\DTLifstringgt
                                  }{\@ifstar\@sDTLifstringgt\@DTLifstringgt}
(That makes 100 errors; please try again.) 
Here is how much of TeX's memory you used:
 28430 strings out of 493323
 521541 string characters out of 3139069
 871146 words of memory out of 3000000
 31664 multiletter control sequences out of 15000+200000
 3938 words of font info for 15 fonts, out of 3000000 for 9000
 1141 hyphenation exceptions out of 8191
 61i,1n,53p,10452b,277s stack positions out of 5000i,500n,10000p,200000b,50000s

!  ==> Fatal error occurred, no output PDF file produced!

Here my code, that doesn't work:

\documentclass[12pt, parskip=half, headheight=35.1pt, footheight=21.75pt]{Klassen/meineKlasse}

\usepackage[backend=biber]{biblatex}
\usepackage{csquotes}
\addbibresource{Bibliothek/literatur.bib}

\usepackage{caption}
\usepackage{subcaption}
\usepackage[footsepline, automark]{scrlayer-scrpage}
\usepackage{scrhack}
\usepackage{hyperref}

\usepackage{etoolbox}
\usepackage{textgreek}
\usepackage{textcomp}
\usepackage{graphicx}
\usepackage{wrapfig}
\usepackage[dvipsnames]{xcolor}
\usepackage{listingsutf8}

\captionsetup[figure]{labelfont={small,it}, textfont={small,it}}

\usepackage{Styles/neueKommandos}
\usepackage{Styles/meinStyleKFZeile}
\usepackage{Styles/meinListingsStyle}

\usepackage{glossaries}

\hypersetup{
  pdftitle=A Title,
  pdfauthor=Author,
  pdfsubject=Thesis,
  pdfkeywords={Some, Keywords},
}

%\makeglossaries

%\newglossaryentry{test}{name={Test},description={Dies ist nur ein Test}}

\begin{document}

%-------------------------------------------------------------------- 
%Verzeichnisse
%\include{Inhalt/Verzeichnisse}

%---------------------------------------------------------------------
\sffamily

%---------------------------------------------------------------------


%-----------------------------------------------------------------------
%\include{Inhalt/Einleitung}

%---------------------------------------------------------------------
%\include{Inhalt/Tests}

\printbibliography

%\printglossaries

\end{document}

Code in neueKommandos.sty

\newtoggle{InString}{} % Keep track of if we are within a string
\togglefalse{InString} % Assume not initally in string

\newcommand*{\ColorIfNotInString}[1]{\iftoggle{InString}{#1}{\color{red}#1}}
\newcommand*{\ProcessQuote}[1]{#1\iftoggle{InString}{\global\togglefalse{InString}}{\global\toggletrue{InString}}}

Code in meinListingsStyle.sty

\definecolor{javared}{rgb}{0.6,0,0} % for strings
\definecolor{javagreen}{rgb}{0.25,0.5,0.35} %comments
\definecolor{javapurple}{rgb}{0.5,0,0.35} %keywords
\definecolor{javadocblue}{rgb}{0.25,0.35,0.75} %javadoc

%Einstellungen für das Design des Quellcodes
\lstset{
    language            =   {Java},
    extendedchars       =   true,
    inputencoding       =   utf8,
    basicstyle          =   \ttfamily\DeclareFontShape{OT1}{lmtt}{m}{it}{<->sub*lmtt/m/sl}{},
}

\lstMakeShortInline[columns=fixed]|
%Fürs Zahlen highlighting und Umlaute
\lstset{literate=%
    {"}{{{\ProcessQuote{"}}}}1 % Disable coloring within double quotes
    {'}{{{\ProcessQuote{'}}}}1 % Disable coloring within single quotes
    {0}{{{\ColorIfNotInString{0}}}}1
    {1}{{{\ColorIfNotInString{1}}}}1
    {.0}{{{\ColorIfNotInString{.0}}}}2
    {.1}{{{\ColorIfNotInString{.1}}}}2
    {\ }{{ }}1 %handle the space
    {Ö}{{\"O}}1
    {Ä}{{\"A}}1
    {Ü}{{\"U}}1
    {ß}{{\ss}}1
    {ü}{{\"u}}1
    {ä}{{\"a}}1
    {ö}{{\"o}}1 
}

%Einstellungen für die Variablen im Quellcode
\lstset{
    morekeywords    =   {grammar, generate, enum, with},
    emph            =   {name}
}

When i comment \usepackage{Styles/meinListingsStyle}, i get no error


\usepackages{glossaries-german} causes a cannot find error

Please can somebody help me

  • 1
    Welcome to TeX.SX! Please do not post only error messages from the log file but additionally a minimal but working example (MWE) to reproduce these error messages. This would help to understand the problem and to test our suggestions. Please help us to help you. And what is lstingsutf8? Do you mean listingsutf8? Note, it does not support utf8 in \lstinline. – Schweinebacke May 31 '17 at 6:28
  • 1
    Your used packages cannot replace a MWE. Please following the link in my comment. And please have a look into the Help Center to learn more about the format we use here and how to use Markdown to format your posts. – Schweinebacke May 31 '17 at 6:48
  • 1
    The example is not working, because of the .... in \lstset. If I remove them, it does not result in any of the errors shown in the question. – Schweinebacke May 31 '17 at 7:27
  • 1
    Now, the example is also not working because we do not have example.png. But if I additionally replace it by example-image it does not influence the result. So it seems to be not needed and should be removed from the example. Again: This is not a MWE and the shown error messages do not correspond with the example. – Schweinebacke May 31 '17 at 7:40
  • 1
    Now, the example is also not working because of other missing files. And surely it is not minimal. With every edit you make things worse. Please read the answers at the MWE link in my first comment and also some of the pages about how to make such a MWE in these answers. And sorry, now I'm out of time. Hope someone else can help you. – Schweinebacke May 31 '17 at 7:53
1

glossaries-german does not provide any package (sty-file). It provides a German language module for package glossaries. So

\usepackage{glossaries-german}

will always result in an error message. The language module does not need an explicit usage and you should not use such a command. If glossaries-german.ldf from glossaries-german is installed, glossaries will use it automatically if required.

0

The problem was the \lstMakeShortInline[columns=fixed]|, before the \usepackage{glossaries}. When i write it after glossaries it compiles without errors

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.