1

I am using scrreprt for my thesis. I started writing at the company I worked with but now my contract ended and I have to finish writing at home. When recompiling at home I was surprised to see that the margins changed. The top margin is now much smaller. At work I was using a Linux-machine (OpenSuse) while I am now working under Windows 10. Texstudio was the editor in both cases.

Any ideas why the margins changed? I can set them manually but it would be very interesting to see why this happened. I didn't notice any other differences.

Finding a minimal example is difficult as I don't have access to my previous machine anymore. This is the Setup I am working with now:

\documentclass
 [   twoside=false,    
    fontsize=12pt,    
    DIV=15,         
    BCOR=17mm,     
    headnosepline,    
    footnosepline,  
    paper=a4paper,   
    abstract=true,     
    listof=totoc,       
    bibliography=totoc, 
    titlepage,        
    headinclude=true, 
    footinclude=false,
    numbers=noenddot  
 ]   {scrreprt}  

\usepackage{blindtext}

\begin{document}
\Blindtext
\end{document}

Edit: This is the output from the .log files.

New machine:

Package typearea Info: These are the values describing the layout:
(typearea)             DIV  = 15 
(typearea)             BCOR = 48.36967pt
(typearea)             \paperwidth     = 597.50793pt
(typearea)             \textwidth      = 439.31064pt
(typearea)             DIV departure   = -4% 
(typearea)             \evensidemargin = 31.01349pt
(typearea)             \oddsidemargin  = 31.01349pt
(typearea)             \paperheight    = 845.04694pt
(typearea)             \textheight     = 679.0pt 
(typearea)             \topmargin      = -55.80853pt 
(typearea)             \headheight     = 18.125pt 
(typearea)             \headsep        = 21.75pt
(typearea)             \topskip        = 12.0pt
(typearea)             \footskip       = 50.75pt
(typearea)             \baselineskip   = 14.5pt
(typearea)              on input line 1509. )

Old machine:

Package typearea Info: These are the values describing the layout:
(typearea)             DIV  = 15 
(typearea)             BCOR = 48.36967pt 
(typearea)             \paperwidth     = 597.50793pt
(typearea)             \textwidth      = 439.31064pt
(typearea)             DIV departure   = -4% 
(typearea)             \evensidemargin = 0.94843pt
(typearea)             \oddsidemargin  = 12.7089pt 
(typearea)             \paperheight    = 845.04694pt
(typearea)             \textheight     = 650.0pt
(typearea)             \topmargin      = -15.93353pt 
(typearea)             \headheight     = 18.125pt
(typearea)             \headsep        = 21.75pt
(typearea)             \topskip        = 12.0pt
(typearea)             \footskip       = 50.75pt
(typearea)             \baselineskip   = 14.5pt
(typearea)              on input line 1485. )

Still no idea where the difference comes from though.

  • Welcome to TeX.SX! Would you please add the versions of KOMA on both computers? – TeXnician Jun 1 '17 at 13:57
  • Note that the last lines state "on input line 1509" vs. "on input line 1485". I don't know if it refers to log or .tex file line... but it should be an idea to investigate. Anyway, are your both TeX distro up to date? You might use MikeTeX on Win10, you could also try to install TeXlive (as it should have been the case on OpenSuse) – ebosi Jun 1 '17 at 14:25
  • Old computer: Document Class: scrreprt 2015/05/06 v3.17a KOMA-Script document class (report) New computer: Document Class: scrreprt 2015/10/03 v3.19a KOMA-Script document class (report) – heuamoebe Jun 1 '17 at 14:33
  • Unfortunately I don't have access to the old computer anymore, just an old .log file. Changing headinclude doesn't seem to have any effect. – heuamoebe Jun 1 '17 at 14:33
  • Remove headnosepline because there is by default no headsepline. Or use \KOMAoptions{headinclude=true}\recalctypearea after loading the class. – esdd Jun 1 '17 at 14:50
3

Current KOMA-Script version is 3.23. I would suggest to update your system.

I guess the machine with the smaller top margin uses KOMA-Script version 3.19 or 3.19a. There was a bug in the handling of options headsepline and headinclude: if there was a headsepline option in the class options, headinclude have had no affect when it was set in the class options too, even it comes after headsepline.

enter image description here

enter image description here

enter image description here

enter image description here

As you can see in the pictures below versions 3.19 and 3.19a are ignoring the headinclude=true in the class options because there was a headsepline=false too.

Code:

\documentclass [ twoside=false,
 fontsize=12pt,
 DIV=15,
 BCOR=17mm,
 headsepline=false,% <- syntax changed
 footsepline=false,% <- syntax changed
 paper=a4,% <-changed
 abstract=true,
 listof=totoc,
 bibliography=totoc,
 titlepage,
 headinclude=true,
 footinclude=false,
 numbers=noenddot
 ] {scrreprt} 
\usepackage{blindtext}
\begin{document}
\KOMAScriptVersion

\Blindtext
\end{document}

Note that I have changed the old options to the new syntax. But you can remove headsepline=false, footsepline=false and paper=a4, because they are the defaults.


If you really want to use the old version 3.19a and get the same top margin as with version 3.17a then either remove the not needed headsepline=false (no headsepline is default) or use \KOMAoptions{headinclude=true}\recalctypearea.

  • Great! That changed everything back to the margins I am used to. How do I update KOMA-Script? With Miktex or with Texstudio? – heuamoebe Jun 1 '17 at 15:00
  • With MiKTeX. But I am afraid that there are many other packages that should be updated. Please read first: How should one maintain and update a MiKTeX installation? – esdd Jun 1 '17 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.