9

I've spend the day looking for an answer to this, and I can't find it. I hope one of you can help me out.

I updated MikTex 2.9 and several packages today (using the update wizard) and I can no longer compile my thesis. After using this wonderful website to solve several problems, I'm left with, I hope, one more:

Trying to compile (pdfLaTeX+MakeIndex+BibTeX), I get this error:

Sorry, but "MiKTeX Compiler Driver" did not succeed.

The log file it recommends looking at says just the following:

2017-06-01 16:59:16,602-0400 INFO texify - starting with command line: 2017-06-01 16:59:16,608-0400 INFO texify - running 'initexmf --enable-installer --quiet --update-fndb' to refresh the file name database

I've tried compiling from command line, as suggested in other threads for similar-sounding problems, but that didn't change anything.

I notice that I can compile some other documents, but not all documents. So far, I've only noticed strange behaviour with documents involving .jpg images (not .png or .eps). However, I have a beamer presentation including 1 .jpg image which does compile, so the images apparently are not causing the problem. However, whether I compile from command line or through TeXworks, .jpg images do not show up in the TeXworks viewer (they do show up in Adobe). So I don't know if this is related or not.

I'm not even sure what other information would be helpful. Please let me know if you have any ideas or think some other info would help.

Thanks!

  • 2
    I think the culprit may be MakeIndex. Running pdfLaTeX and BibTeX separately seem to work, excep that TeXworks still can't display jpegs. Running MakeIndex itself gives the error, "Couldn't find input index file, fname nor fname.idx". – user135117 Jun 1 '17 at 21:27
  • Don't use texify. At least not when you get errors. It doesn't show good error messages and so it is very difficult to debug. Run pdflatex directly. – Ulrike Fischer Jun 1 '17 at 21:28
  • Does that have to be done in command line? I've done that and it seems to compile, but I still get the missing jpeg problem. I can't find anyone else saying TeXworks doesn't show their jpegs even though opening the pdf in another viewer does show them. Edit: Can I upvote comments? I would like to show my appreciation for your input haha – user135117 Jun 1 '17 at 22:55
  • You say "I updated MikTex 2.9 and several packages". I would consider letting MikTeX update all the packages it wants. The other day, I upgraded a few packages, and then XeLaTeX would not compile, until I let it upgrade others. Note also that you may need to run several invocations of update to get it all synchronized. – Steven B. Segletes Jun 22 '17 at 14:02
  • I got the error message when the pdf file was opened in another application and which write protected it. – Daniel Jul 2 '18 at 12:38
8

I had a similar problem caused by the pdf being open in adobe. I guess it couldn't save the pdf as it was open in another package.

  • How does this answer help in solving the problem? – Aaron John Sabu Aug 15 '18 at 13:20
2

I have also encountered a similar error like this. Sorry, but “MiKTeX Compiler Driver” did not succeed I tried to delete the log file .synctex.gz etc. compiling files. Suddenly, it worked. I don't know why. But I highly recommend you try to do it.

2

I also encountered the same problem after updating the miktex. I do not know a proper working solution but I could recompile it after deleting all Aux files, as well as close the output pdf before compiling if it is already open in adobe-pdf or any other program.

  • Welcome to TeX.SX! Could you please elaborate on the details of your answer? – TeXnician Jun 9 '17 at 16:41

protected by Community Jul 3 '17 at 19:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.