I have just installed the texlive-full 2016 using install-tl on Ubuntu 16.04. I then installed TeXMaker, which appears to have installed the basic texlive 2015 version over the top of the 2016 commands that I want. For example

$ pdflatex --version 
pdfTeX 3.14159265-2.6-1.40.16 (TeX Live 2015/Debian)

Because of this version conflict nothing will compile (the pdflatex command can't find the 2016 .sty files etc.)

How do I tell my system to use the 2016 latex system?

$ locate -b '\pdflatex'

You can avoid installing texlive 2015 when you install TeXmaker. You have to tell apt not to install the recommended packages.

# apt-get --no-install-recommends install texmaker
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libqt5qml5 libqt5quick5 libqt5webkit5 libsynctex1 texmaker-data
Suggested packages:
Recommended packages:
  texlive-lang-english asymptote
The following NEW packages will be installed:
  libqt5qml5 libqt5quick5 libqt5webkit5 libsynctex1 texmaker texmaker-data
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 15.9 MB of archives.
After this operation, 59.6 MB of additional disk space will be used.
Do you want to continue? [Y/n]

This avoids installing texlive from the debian/ubuntu repo.

Alternatively, you can use equivs to create a dummy texlive package which "satisifies" the dependencies which require texlive* packages from the repo.

  • Might need to use sudo. Or, might need to download the package first, then install using dpkg. A few other packages will be needed, but not texlive. That's how I did it on Ubuntu 16.04 (in my case, the GUI I wanted was TeXworks). – user103221 Jun 2 '17 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.