I am using the package nomencl to generate a list of abbreviations. However, after a recent MiKTeX 2.9 update (using TeXnicCenter) I keep getting errors for the abbreviation items

LaTeX Error: Lonely \item--perhaps a missing list environment.

Unfortunately, I cannot figure out an MWE (the MWE that I tried do work, but the real document doesn't). So here is a shortened version of my main document (without all the other header stuff and bibliography):

\renewcommand{\nomname}{List of Abbreviations}

\printnomenclature \newpage

However, if instead of including the chapters I simply try out an MWE with the same header and one abbreviation:

\printnomenclature \newpage
This is my txt \abk{txt}{text}

then everything works fine. Any suggestions about the reason?

closed as too localized by lockstep, Marco Daniel, Seamus, Joseph Wright Dec 9 '11 at 10:08

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Try to successively remove parts of the main document until the error disappears. – gerrit Dec 6 '11 at 14:45
  • Try \input instead of \include. – Count Zero Dec 6 '11 at 15:14
  • 3
    @gerrit: Due to the kind of the error message I thought it is a general problem rather than text-dependent. I followed your advice and after 2 hours trying to narrow down the problem area I finally found the reason: One of the abbreviations was defined twice. – Anja Dec 6 '11 at 17:29
  • @Anja: Please turn your comment into an answer. – lockstep Dec 6 '11 at 22:46
  • 1
    This is why making a minimal example should be done before asking a question… – Seamus Dec 7 '11 at 11:10

The problem was, that one of the abbreviations was defined twice. After removing the duplicate item everything works fine.

  • 1
    You saved my day, a similar problem was bugging me, and your note on duplicate definitions solved my problem. Which was indeed caused by duplicate nomenclature definitions. – Dohn Joe Nov 3 '15 at 14:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.