2

I download texlive 2017 from this link with rsync. I run install-tl-advanced.bat. (Run as admin in windows) but i got this error:

the program cant start because perl522.dll is missing from your computer.
try reinstalling the program to fix this problem

then i install perl. but The problem was not solved. I go to this links:

ftp://ftp.dante.de/tex-archive/systems/texlive/tlnet/tlpkg/tlperl/bin/

and

rsync: ctan.asis.io/systems/texlive/tlnet/tlpkg/tlperl/bin/

this file's Do not exist:

libgcc_s_sjlj-1.dll  -  perl5.22.1.exe - perl522.dll

But in:

http://ctan.yazd.ac.ir/systems/texlive/tlnet/tlpkg/tlperl/bin/?C=N;O=A http://ctan.um.ac.ir/systems/texlive/tlnet/tlpkg/tlperl/bin/

(libgcc_s_sjlj-1.dll  ,  perl5.22.1.exe , perl522.dll) are exist.

when i copt these file to mu texlive folder and then begin install, i get this error:

install-tl" -gui perltk
"is_seven" is not exported by the TeXLive::TLWinGoo module
Can't continue after import errors at Z:\texlive\install-tl line 64.
Press any key to continue . . .

that 3 files was exist in texlive pretest. but, was deleted in "texlive 2017" first release (today). (but exist in install-tl.zip file)

what is solution? thanks

  • 4
    I'm not sure if you should install now. Not everything is already on all mirrors, I e.g. don't get updates for my pretest installation. So perhaps you didn't get everything. The needed perl is normally part of texlive: In my pretest installation perl522.dll is in tlpkg/tlperl/bin. – Ulrike Fischer Jun 4 '17 at 13:54
  • If you have rsync-ed a TeX Live repository you should explicitly use that rsync-ed repository for the installation. I do not know the Windows version of the installer. But in the Linux version this can be done using option -repository <path to local repository>. – Schweinebacke Jun 4 '17 at 14:18
  • @Ulrike Fischer thanks. "In my pretest installation perl522.dll is in tlpkg/tlperl/bin" yes. also for me. but in texlive 2017 was deleted. but exist in install-tl.zip. i test this mistake in several windows and clean windows's. and happened. – Hadi Safi aghdam Jun 4 '17 at 14:49
  • @Schweinebacke thanks. but, I do. In windows, installer chooses itself local repository automatically. – Hadi Safi aghdam Jun 4 '17 at 14:51
  • 2
    Why are you installing a new texlive if you already have the pretest? Anyway I think you should wait a day and then try again. – Ulrike Fischer Jun 4 '17 at 14:57
1

After today's update, the problem was solved. texlive maintainer was added newer version of 3 file to \texlive\tlpkg folder.

(libgcc_s_sjlj-1.dll  ,  perl5.24.1.exe , perl524.dll)

There may be other corrections ... .

thanks best wishes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.