6

I am experiencing some strange behavior of the Russian babel package: whenever there is a combination of '",' (quotation mark with following comma) it is simply ignored. Below is a minimum example:

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[english, russian]{babel}

\begin{document}
    English: "once upon a time", "there was a king".\\
    Русский: "жил-был царь", "в тридевятом королевстве".
\end{document}

(see image below for what I am getting). The error is in both English and Russian texts. enter image description here

If I remove "russian" from {babel} in the header and the Russian line from the document, everything starts to work okay again, as in the code below:

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}

\begin{document}
    English: "once upon a time", "there was a king".
\end{document}

Does anybody know of a workaround to this phenomenon? I am using TexStudio 2.12.2 over MikTex 2.9, OS = Windows 10.

0

1 Answer 1

7

The " character is for babel the sign that it uses a shorthand at this place. You can prevent that shorthand by using "{}, but the better option would be to use the right opening and closing quotes (see first two lines in the picture).

quotes

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[english, russian]{babel}

\begin{document}
    English: ``once upon a time'', ``there was a king''.\\
    Русский: ``жил-был царь'', ``в тридевятом королевстве''.\\
    English: "once upon a time"{}, "there was a king".\\
    Русский: "жил-был царь"{}, "в тридевятом королевстве".
\end{document}
6
  • @AlexKonnen No, the "{} version doesn't work, it has by design wrong characters. But however, the usual way to say thanks on this site is to upvote an answer (or, if it solves your problem, to accept it with the green button on the left).
    – TeXnician
    Jun 5, 2017 at 8:44
  • But still strange, if " is used as a shorthand sign, that it does not happen when I only use English. Anyway, i was looking for a workaround, and I got it. Jun 5, 2017 at 8:44
  • @AlexKonnen Babel's shorthands are language-specific.
    – TeXnician
    Jun 5, 2017 at 8:44
  • I have tried to upvote you, but I am not entitled to by the system: I do not have enough reputation points. I know this emeritocratic discrimination policy quite well from stockoverflow. Therefore all i can cordially do is to express my verbal thanks. :-) Jun 5, 2017 at 8:46
  • Let us continue this discussion in chat. Jun 5, 2017 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.