I am copying the very first piece of code from ShareLatex in order to create a glossary. While I get no problem in the compilation I do not get the "glossary part" that appears in the example. I literally copy paste.

Also, I want to create a document that only consists of a glossary of various terms. That is to put everything in alphabetical order (with the possibility to include references as well). How could I possibly do this? I tried some itemize options with alphabetical order but does not look that good.

  • 1
    Have you run the makeglossaries script as well or tried \makenoidxglossaries etc. ?
    – user31729
    Jun 7 '17 at 15:45
  • No, I just copied the code I found in ShareLatex. Do I do this in the preamble?
    – Gorbz
    Jun 7 '17 at 15:47
  • 1
    Please go the section 'Compiling the glossary' in the ShareLaTeX link you provided above..., it's at the bottom of that web page
    – user31729
    Jun 7 '17 at 15:49
  • 2
    I've no idea what you are talking about -- I have done many glossaries and answered many questions about it....
    – user31729
    Jun 7 '17 at 16:41
  • 1
    Are you trying to build the document in ShareLaTeX or on your local drive? If on ShareLaTeX, it should build it automatically. If on your local drive, what setup do you have (e.g. TeXworks, latexmk, WinEdt)? Jun 7 '17 at 17:35

I will show you how to do it via command line on Windows 10. This can be done on Linux and Mac, or through your front-end (if you find out how to do it).


  1. Run pdflatex file.tex (or lualatex or xelatex): enter image description here
  2. Run the file without extension with makeglossariesenter image description here
  3. Do 1 again.
  4. Enjoy the glossaries.enter image description here

Some explanation: \makeglossaries in the preamble tells TeX to collect all the related stuff and put it to the .glo file. When you execute makeglossaries gl or makeglossaries gl.glo from cmd, the file with extension .gls is created, which is used when compiling the main file (that's why the first run gives you a warning gl.gls not found).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.