1

I'm absolutely new in with LaTeX.

I have try a lot of things to have juste a small black border around my box, but when I generate the PDF or when I run, text is here, but there is nothing around.

Maybe I do have a problem with Texmaker?

Sorry, I'm a french speaker. I guess, my English is by far not perfect.

My code is:

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\begin{document}
\makebox[\textwidth]{c e n t r a l}
\end{document}

Do you have any idea?

Thanks you so much. I'm loosing lot of time to try make it work.

  • You have to use \framebox, not \makebox. – egreg Jun 8 '17 at 10:52
  • Or \fbox instead of \framebox – user31729 Jun 8 '17 at 10:53
2

\makebox does not draw a frame at all.

Either use \framebox or \fbox (which does not span to the \textwidth, however) or the more sophisticated tcolorbox environment.

There are other possibilities with mdframed etc.

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage[most]{tcolorbox}
\begin{document}
\parindent=0em
\framebox[\textwidth]{c e n t r a l}

\fbox{c e n t r a l}

\begin{tcolorbox}[enhanced,sharp corners,colback=white,halign=center]
  c e n t r a l
\end{tcolorbox}



\end{document}

enter image description here

  • Wow, impessing reactivity thanks you so much. Actually, I tried and it works. But on my full report, i have this package '%\usepackage[dvips,table,xcdraw]{xcolor}' and apparently when I activate this, the black line around the text disapear. Maybe you have an idea why? thanks you so much. – Simon Says Jun 8 '17 at 12:25
  • @SimonSays: That's the cause why you should always post a working example ;-) Remove the xcdraw option (it's a guess only, however) – user31729 Jun 8 '17 at 12:31
  • Yes, you're right, but I had a list of package and mess long like the bible. But you're right. I deleted dvips, and actually it works. Thanks you so much. – Simon Says Jun 8 '17 at 12:36
  • @SimonSays: I am wondering why you're using the dvips at all nowadays. – user31729 Jun 8 '17 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.