I have just downloaded MikTeX Portable, installed the latest Babel package on-the-fly (with this strange arabi package), and still got a hyphenation error with Hungarian Babel:

Kipróbáljuk, hogy működik-e az elválasztás hosszú szavaknál: megszentségteleníthetetlenségeskedéseitekért.

Package magyar.ldf Warning: All Hungarian hyphenation= patterns missing. To make LaTeX hyphenate Hungarian words, please modify language.dat and rerun initex or texconfig.

I'm using Windows 10 and TeXnicCenter 2.02 if that matters. Do you have any ideas how may I solve it? Thank you in advance!


2 Answers 2


You can download a lot of things, for example the magyar.ldf from this website: https://math.bme.hu/latex/

  • The file is there, it's just not recognised by the system somehow :-( Feb 22, 2018 at 14:05
  • It should be on LaTeX's path, the easiest to do that is by simply placing it into the same folder as your tex file.
    – fbence
    Feb 22, 2018 at 14:10

I gained inspiration from this old SE question. The only thing I had to do was to go to the \texmfs\install\miktex\bin folder, run mo.exe and on the General tab press Update formats. After that everything works perfectly, no warning messages, correct hyphenation.


Please note that in more recent versions, the mo.exe was replaced with the console.

  • Doing something with admin rights on a portable installation can't be right or necessary. It is quite possible that you need to recreate the formats to activate the patterns, but then better do it through the miktex terminal you can see in the tray icon. Call there mo.exe to open miktex settings. Mar 5, 2018 at 10:57
  • @UlrikeFischer Fair point, and admin mode is not needed at all eventually (so I've edited it out). To answer your other question, Hungarian was checked among the languages. Mar 5, 2018 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .