4

I am using this template: https://www.overleaf.com/latex/templates/template-for-a-masters-slash-doctoral-thesis/mkzrzktcbzfl

I have already turned on consistentlayout, but it keeps displaying author name and thesis title in the abstract. How do I fix this?

enter image description here

1

2 Answers 2

3

Add these lines to your header (I put them right before the "Margin settings" comment):

\DeclareDocumentEnvironment{abstract}{ O{} }{%
    \addchap*{\abstractname}%
    \bigskip\noindent\ignorespaces
}%
{}

For comparison, the code executed by the template when the option consistentlayout is set (from here):

\DeclareDocumentEnvironment{abstract}{ O{} }{%
    \addchap*{\abstractname}%
    {\chapteralign\normalsize\abstractauthorfont \authorname \par} % Author name
    \vspace{\baselineskip}
    {\chapteralign\parbox{.7\linewidth}{\chapteralign\normalsize\itshape\abstracttitlefont\@title}\par}% Thesis title
    \bigskip\noindent\ignorespaces
}%
{}

So I just removed the lines that insert the author name and thesis title into the abstract page.

3

The simplest possible way would be to use

\addchap{Abstract} 

Abstract text here

Instead of redefining some commands

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .