1

texlive 2017 on Linux. Commercial fonts are installed in /texmf-local . Under texlive 2017 the local fonts files are not found, while they are found under texlive 2015 on the same machine. Both installations use the same /texmf-local tree.

Here is an MWE:

\documentclass[pagesize, ngerman, fontsize=12pt, parskip=half]{scrartcl}
\usepackage[T1]{fontenc}\usepackage[utf8]{inputenc}
\usepackage{babel, blindtext}

\usepackage{MinionPro}

\begin{document}
\blinddocument{}

\end{document}

If I compile this MWE with texlive 2015, the logfile ends with these lines:

{/local/texlive/texmf-local/fonts/e
nc/dvips/MinionPro/base-MinionPro-aa.enc}{/local/texlive/2015/texmf-dist/fonts/
enc/dvips/cm-super/cm-super-t1.enc}{/local/texlive/texmf-local/fonts/enc/dvips/
MinionPro/base-MinionPro-ab.enc}</local/texlive/texmf-local/fonts/type1/adobe/M
inionPro/MinionPro-Bold.pfb></local/texlive/texmf-local/fonts/type1/adobe/Minio
nPro/MinionPro-Regular.pfb></local/texlive/2015/texmf-dist/fonts/type1/public/c
m-super/sfsx1200.pfb></local/texlive/2015/texmf-dist/fonts/type1/public/cm-supe
r/sfsx1440.pfb></local/texlive/2015/texmf-dist/fonts/type1/public/cm-super/sfsx
1728.pfb>
Output written on MinionPro-test-tl-2015.pdf (4 pages, 119264 bytes).
PDF statistics: ...

But texlive 2017 can't find the fonts:

!pdfTeX error: pdflatex (file MinionPro-Bold-Base-aa): Font MinionPro-Bold-Base
-aa at 655 not found
 ==> Fatal error occurred, no output PDF file produced!

But the kpathsea knows, where to find the file:

 kpsewhich base-MinionPro-aa.enc
/local/texlive/texmf-local/fonts/enc/dvips/MinionPro/base-MinionPro-aa.enc

Maybe I made a mistake during installation of texlive 2017: I agreed to make symbolic links. If this might be the cause of the error, can I correct that without reinstalling texlive?

There are no other TeX installations on the machine.

  • "at 655" means normally that pdftex was trying to make a bitmap. So the map entry is missing. Did you enable the map files? – Ulrike Fischer Jun 9 '17 at 15:54
  • @UlrikeFischer Öhh, no? Do I have to? In which file is stored, which map files are enabled? If I knew this, I could have a look into the texlive 2015 installation and see, which files were enabled in which way. You may remember that I had some rare fonst, e.g. Palatinosans, which only work with pdftex. – Keks Dose Jun 9 '17 at 16:03
  • Search for updmap.cfg in web2c-folders. Or try updmap-sys --enable Map=MinionPro.map – Ulrike Fischer Jun 9 '17 at 16:25
  • @UlrikeFischer You are right, I haven't made a new install of texlive since some years. After I »enabled« the map files, all is well. Would you drop two or three lines, which I could accept as an answer? -- And thank you for your timely help. – Keks Dose Jun 9 '17 at 16:39
  • TL 2017 finds mine even though I told it it must not try to make symbolic links. – cfr Jun 10 '17 at 1:08
5

"at 655" means normally that pdftex was trying to make a bitmap. So the map entry is missing. Try updmap-sys --enable Map=MinionPro.map.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.