3

This is probably a problem with an easy solution, but I am very new to using LaTeX and I have not been able to find the solution.

Anyhow, I am working in Sharelatex on a thesis, and I am using a chicago-authordate-ish bibliography version in biblatex. The problem grew out of me trying to add a newspaper article to my bibliography. When using the following code I could not get the date of the article to show up in the bibliography:

\documentclass[a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber, style=chicago-authordate,sorting=nyt,cmsdate=both,maxcitenames=2]{biblatex}

\begin{filecontents}{bibliography.bib}
@article{blakeslee1947,
  title={'Flying Saucers' Called Forerunners of the New Atomic Folklore},
  author={Howard W. Blakeslee},
  journal={The Washington Post},
  pages={B2},
  date={1947-07-20},
  entrysubtype={newspaper},
}
@book{Dorson1971a,
author={Richard M. Dorson},
title={American folklore},
publisher={University of Chicago Press},
address={Chicago},
year={1971},
origdate={1959},
}

\end{filecontents}
\addbibresource{bibliography.bib} 
\begin{document} 
text \footnote{\cite{blakeslee1947}; \cite[][p. 78]{Dorson1971a}}
\printbibliography
\end{document}

Using this code the output became:

enter image description here

When searching for a solution to the missing date in the reference to the article from the Washington post I found an article (Difference between biblatex [style=chicago] and biblatex-chicago packages?) stating that the proper way to call on this style would be like this:

    \documentclass[a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber, style=authordate,sorting=nyt,cmsdate=both,maxcitenames=2]{biblatex-chicago}

\begin{filecontents}{bibliography.bib}
@article{blakeslee1947,
  title={'Flying Saucers' Called Forerunners of the New Atomic Folklore},
  author={Howard W. Blakeslee},
  journal={The Washington Post},
  pages={B2},
  date={1947-07-20},
  entrysubtype={newspaper},
}
@book{Dorson1971a,
author={Richard M. Dorson},
title={American folklore},
publisher={University of Chicago Press},
address={Chicago},
year={1971},
origdate={1959},
}

\end{filecontents}
\addbibresource{bibliography.bib} 
\begin{document} 
text \footnote{\cite{blakeslee1947}; \cite[][p. 78]{Dorson1971a}}
\printbibliography
\end{document}

This proved to amend the problem with the missing date, but I do now instead get a different layout of the bibliography and the footnotes, is there any easy way to get the style of the first example back without having to revert back to the first code-example?:

enter image description here

  • What happens if you keep style=chicago-authordate in the second code block? – cfr Jun 10 '17 at 3:00
  • Your second printout, doesn't seem at all to be produced by \footnote{\cite{blakeslee1947}; \cite[][p. 78]{Dorson1971a}} on an authordate style. Your second example trows an error to me, but if I give just authordate as an option to biblatex-chicago (that is, not style=authordate, just authordate), I get results very similar to your first printout, with the newspaper date. Which seems to be what you want. – gusbrs Jun 10 '17 at 3:05
  • @cfr there is sadly no difference in the output – Erik Jun 10 '17 at 3:06
  • @gusbrs, when I try that the dates for the newspaper disappears again for me. – Erik Jun 10 '17 at 3:08
  • 1
    So you do get a style undefined error. That means you were not loading the authordate style at all, for the default of biblatex-chicago is notes. – gusbrs Jun 10 '17 at 11:29
1

I was looking again biblatex-chicago's documentation, and what it says about the case is the following:

The Manual now suggests that, no matter which citation style you are using, it is “usually sufficient to cite newspaper and magazine articles entirely within the text” (15.47). This involves giving the title of the journal and the full date of publication in a parenthetical reference, including any other information in the main text (14.206), thereby obviating the need to present such an entry in the list of references. To utilize this method in the author-date styles, in addition to a magazine entrysubtype , you’ll need to place cmsdate=full into the options field, including skipbib there as well to stop the entry printing in the list of references. If the entry only contains a date and journaltitle that’s enough, but if it’s a fuller entry also containing an author then you’ll also need useauthor=false in the options field. Other surplus fields will be ignored. (See osborne:poison.)

So it seems that the problem with the missing date is that biblatex-chicago doesn't expect to print it in the bibliography. (Still, for me it prints the year by the author, and month and date later in parentheses). Anyway, following the documentation, you could use:

\documentclass[a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[authordate]{biblatex-chicago}

\begin{filecontents}{bibliography.bib}
@article{blakeslee1947,
    title={`Flying Saucers' Called Forerunners of the New Atomic Folklore},
    author={Howard W. Blakeslee},
    journaltitle={The Washington Post},
    pages={B2},
    date={1947-07-20},
    entrysubtype={magazine},
    options={cmsdate=full,skipbib,useauthor=false},
}
@book{Dorson1971a,
    author={Richard M. Dorson},
    title={American folklore},
    publisher={University of Chicago Press},
    address={Chicago},
    year={1971},
    origdate={1959},
}

\end{filecontents}
\addbibresource{bibliography.bib} 
\begin{document} 
    text \footcite[78]{Dorson1971a} \footcite[5]{blakeslee1947}
    \printbibliography
\end{document}

Which results in:

enter image description here enter image description here

I'm not sure that's what you intended, but it seems to be what the current Chicago Manual favors, and what biblatex-chicago implements in practice.

EDIT: what I mean by "make it work for you, even when not following the style's strict guidelines". Try, for example (or something other in similar lines):

@misc{blakeslee1947,
    title={`Flying Saucers' Called Forerunners of the New Atomic Folklore},
    author={Howard W. Blakeslee},
    titleaddon={The Washington Post, 20 July, 1947, p. B2},
    date={1947},
}
| improve this answer | |
  • Thanks. This does indeed seem to be in line with the manual. I might have to consider changing to another style completely since I am pretty sure I will be demanded to list all references in the bibliography. I'll leave it unsolved as of now in case anyone else has an idea on how to tweak this into working. – Erik Jun 10 '17 at 11:57
  • 1
    Well, if the Chicago style is required of you explicitly, then it should not be a problem, for it is covered. But if you need an author-date style and chose Chicago for some other reason, you might consider biblatex's authoryear style. – gusbrs Jun 10 '17 at 12:03
  • 1
    Still, if you remove skipbib from the entry option, it will be printed in the bibliography. What I'm saying is that, most likely, you can also use biblatex-chicago and make it work for you, even when not following the style's strict guidelines. But to set better what your style requirements are, would be a good starting point for you. – gusbrs Jun 10 '17 at 12:12
  • I think they are not that explicit about which style they prefer, it's a washed down version of Chicago or authoryear that comes closest I guess. I have written in the Chicago style for books before so I pretty much just choose that one out of habit and stylistic preference :) – Erik Jun 10 '17 at 12:13
  • 1
    @Erik, I do believe that's the wisest. Choose a style (which is made to be consistent), and stray away from it only if there is good reason to do so. – gusbrs Jun 10 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.