0

I just changed to Sierra. Now my .tex files are shown as textwrangler files. How do I get them converted back to TexShop files. I can open them file/open as TexShop files but I can't double-click open as a TexShop file. I did try version 3.77 and it didn't even do this.

  • Welcome to TeX - LaTeX! This is really a MacOs question. Anyway, locate a .tex file in Finder, then Control-Right click on it and choose Get Info from the menu. You will get a new window, with a section Open with when you can specify the application (Texshop) and also that all files of the same type should be opened in this way. – Andrew Swann Jun 10 '17 at 15:40
2

First do update to version 3.77. Then, in Finder, select any single .tex file and do a Get Info… (Cmd-I). Go to the 'Open with:' section and select TeXShop.app (it may have a version number next to it) and then click on the 'Change All…' button and agree to the change. From then on Double Clicking on any .tex file will open it in TeXShop even though the icon may be wrong. The problem is that TextWrangler (as well as BBEdit) defines a UTI that interferes with that defined by TeXShop.

  • The files now open as TexShop files when double-clicked. However the icon on the files is still TextWrangler (text) not TexShop. – i. m. soloveichik Jun 11 '17 at 13:18
  • 1
    I did mention that above. The problem is that TextWrangler (and BBEdit too) exports a UTI for .tex files that interferes with the one exported by TeXShop. There is no great way to deal with this problem. One thing you might try to do is have the OS rebuild it's meta-data database: drag your HD (Macintosh HD?) to the Privacy tab display of System Preferences->Spotlight (this will remove the old database), quit and reopen that pane and then remove it from that pane. that will force the OS to rebuild the meta-data database. Even that is no guarantee it will fix itself. – Herb Schulz Jun 11 '17 at 13:52
  • Didn't work. I forgot to mention that the icon on Tex shop is generic Tex and not a proper TexShop icon. – i. m. soloveichik Jun 11 '17 at 14:25
  • When you say "generic TeX" did you mean "text" or does it say TeX on the icon? If the latter you might have icon preview turned on. In Finder Open a folder with .tex files in it and choose View->Show View Options (Cmd-I) and uncheck the 'Show icon preview’ button. – Herb Schulz Jun 11 '17 at 21:41
  • It says TeX on the icon. I unchecked as suggested, restarted but nothing has changed. – i. m. soloveichik Jun 12 '17 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.