3

I am attempting to cite a website using biblatex in APA format.

However, it is citing it wrong i.e. an in-text citation looks like the following [1] instead of (Author, Year)

The same goes for the bibliography there should be no [1]. It should look like this:

Inc. How to Conduct Competitive Research. May 2010. URL : https://www.inc.com/guides/2010/05/conducting-competitive-research. html.

Instead of like this:

[1] Inc. How to Conduct Competitive Research. May 2010. URL : https://www.inc.com/guides/2010/05/conducting-competitive-research. html.

This is how my .tex file is set up:

\documentclass{article}
\usepackage{graphicx}
\usepackage{float}
\usepackage{times}
\usepackage{hyperref}
\usepackage{indentfirst}
\usepackage{csquotes} 
\usepackage[backend = biber, hyperref,backref = true style=apa]
{biblatex}
\DeclareLanguageMapping{american}{american-apa}
\addbibresource{mybib.bib}
\usepackage{wallpaper}
\AddToShipoutPictureBG{%
\AtPageUpperLeft{\raisebox{-\height}{\includegraphics[width=1.5in]
{LetterHead.png}}}%
}
\begin{document}
Some text that I am citing \autocite{Inc:2010:Online}
\printbibliography
\end{document}

And this is how my .bib file is set up

@Online{Inc:2010:Online,
author = {Inc},
title = {How to Conduct Competitive Research},
month = {May},
year = {2010},
url = {https://www.inc.com/guides/2010/05/conducting-competitive-
research.html}
}
1

Some comments:

  • You have a comma missing in your biblatex options.
  • You need to load babel to use the apa biblatex style.
  • You should load hyperref last in the package loading order; you don't need to add hyperref as a biblatex option.
  • It's preferable to use numbers for the Date field if you are using biblatex (i.e., 5 instead of May)
  • The times package is deprecated. You should use the newtxtext and newtxmath packages instead.

I've removed irrelevant packages and code from you example and included your sample .bib item using filecontents to make the document self-contained.

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@Online{Inc:2010:Online,
author = {Inc},
title = {How to Conduct Competitive Research},
month = {5},
year = {2010},
url = {https://www.inc.com/guides/2010/05/conducting-competitive-research.html}
}
\end{filecontents*}

\usepackage{newtxtext,newtxmath}
\usepackage{csquotes} 
\usepackage[american]{babel}
\usepackage[backend = biber, backref = true, style=apa]
{biblatex}
\DeclareLanguageMapping{american}{american-apa}
\addbibresource{\jobname.bib}
\usepackage{hyperref}

\begin{document}
Some text that I am citing \autocite{Inc:2010:Online}
\printbibliography
\end{document}

output of code

  • Thank you so much this worked! You are awesome! I just started using latex so I am getting use to the formatting. Why did some examples leave babel out? Thank you for the advice for using numbers for a date (is there a reason for this)? Lastly, how do you find out if packages that are outdated is newtxtext and newtxmath times new roman packages? – thutchi Jun 11 '17 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.