0

I am making a Beamer presentation and want to use the handout option. However, it turns out that when I add [handout] to the document class, the itemize-environment does not work properly and all items are displayed at once, although I specify that they should be revealed pointwise. What is wrong?

Here is my preamble and an example:

\documentclass[handout]{beamer}
\usefonttheme[onlymath]{serif}
\usetheme{CambridgeUS}
\usepackage[french]{babel}
\usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    \usepackage{tipa}
    \usepackage{eurosym}
\usepackage{wasysym}
\usepackage{colortbl}
\usepackage{wrapfig}
\usepackage{graphics}
\usepackage{linguex}
\usepackage{cgloss4e}
\usepackage{csquotes}
\usepackage{xspace}
\usepackage{color}
\usepackage{xyling}
\usepackage{setspace}
\usepackage{amsfonts}
\usepackage{phonetic}
\usepackage{multicol}
\usepackage{booktabs}
\usepackage{multirow}
\usepackage[backend=biber, style=authoryear-comp]{biblatex}
 \let\eachwordone\itshape
\addbibresource{ref2.bib}


\beamertemplateballitem


\title{XXX}
\subtitle{YYY}
\author{XXX}
\institute{Flafla}
\date{\today}

\newcommand{\textunderscript}[1]{$_{\text{#1}}$}

\begin{document}



\frame{


\begin{itemize}

\item<2-> Blabla 

\item<3-> Flafla

\item<4-> Dada

\end{itemize}

}

\end{document}
1
  • 3
    That's not a bug, it's a feature. – TeXnician Jun 11 '17 at 10:44
5

The beamer user guide is very clear about that (mode specifications, 9.6.2):

For this reason, if you write \only<3>{Text} and you are in handout mode, the text will be shown on all slides since there is no restriction specified for handouts and since the 3 is the same as beamer:3.

You have to specify the restrictions for the presentation and for the handout. But be aware, that you usually design a presentation without handout. That option is just used to print the handouts and then removed if you give your presentation.

Here's a real MWE "fixing" your problem (workaround around beamer's design):

\documentclass[handout]{beamer}
\usefonttheme[onlymath]{serif}
\usetheme{CambridgeUS}
\usepackage[french]{babel}

\beamertemplateballitem

\title{XXX}
\subtitle{YYY}
\author{XXX}
\institute{Flafla}
\date{\today}

\begin{document}

\begin{frame}
Test
\begin{itemize}
\item<2- | handout:2-> Blabla 
\item<3- | handout:3-> Flafla
\item<4- | handout:4-> Dada
\end{itemize}
\end{frame}

\end{document}
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.