2

I recently moved to a new computer and have noticed that since installing the latest version of Miktex, compiling my documents no longer produces any auxiliary files whatsoever. The files that I used to see but are no longer generated are the .aux files, .bbl files (for BibTex), .log files, .out files, .thm files and .toc files. There is nothing other than the .pdf and synctex.gz file.

Despite this the pdf displays as usual. This would not bother me otherwise, but I can no longer upload to the arxiv no longer works correctly due to the missing auxiliary files. I am wondering if there is a way to force MikTex to produce the missing files.

  • Welcome to TeX.SX! Normally your TeX compiler should produce the aux files. Do you maybe use an editor that moves the auxiliary files into their own subdirectory or cleans aux files after successful compilation? – moewe Jun 12 '17 at 7:01
  • This is impossible if it compiles... I can only suppose your MiKTeX system is configured so the auxiliary files go to some subdirectory. Which editor do you use? – Bernard Jun 12 '17 at 7:01
  • MikTeX option -output-directory allows you to send all output files to another folder, but the pdf result is also an output file then it should be also hidden. Are you sure that auxiliary files don't exist? Did you look with a dir command from a cmd window? – Ignasi Jun 12 '17 at 7:05
  • For some reason I am not able to comment on my question so I will try to leave this as an "answer" for now. I am using version 0.6.1 of TexWorks (MikTex 2.9.6300 64-bit). Typing dir in cmd window confirms that there are no aux files. I have no idea how it manages to compile (and this has not been an issue on any other computer I've used). Thanks. – user149719 Jun 12 '17 at 7:09
  • 5
    Wild guess: You are using texify --clean ... to compile. This will remove auxiliary files after the compilation. – Ulrike Fischer Jun 12 '17 at 7:14
2

Using @Ulrike_Fischer's suggestion I edited "pdfLaTeX + MakeIndex + BibTeX" in Edit->Preferences->Typesetting and found that --clean was indeed enabled (apparently by default). Deleting this fixed my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.