1

I'm brand new to LyX and am having a huge amount of trouble getting it up and running on Windows 10, and would greatly appreciate any assistance.

  1. Downloaded the installer for LyX 2.2 (LyX-223-Bundle-1.exe) and installed it with all the default options.
  2. If a start a new document, I get three error messages (extarticle.cls is not installed, missing prerequisites knitr->latex, missing prerequisites natbib.sty).
  3. Going to Tools> Configure seems to start MikTex package manager which checks for natbib and eventually gives me the following message: The Command python -tt "C:/Program Files (x86)/LyX 2.2/Resources/configure.py" --binary-dir="C:/Program Files (x86)/LyX 2.2/bin/" has not completed. Do you want to keep running it. After a few iterations it completes, and asks me to restart Lyx, but it still does not seems to have knitr.
  4. Now when I create a new document, I don't have the option of pdf output (my choices are HTML, LyXHTML, MS Word and OpenDocument. Unfortunately, equations don't display nicely in these formats.

At this point, I have absolutely no idea what I am doing wrong, or how I fix it, and would be grateful for any suggestions and assistance, preferably in simple (i.e. minimally technical) terms.

Many thanks in advance

Thomas Philips

  • Seems a hardcore LyX question. Would you subscribe and ask on the LyX-Users mailing list: mail-archive.com/lyx-users@lists.lyx.org/info.html ? If you do that, please mention the crosspost there. – Keks Dose Jun 14 '17 at 15:59
  • extarticle and natbib can be installed via the MikTeX package manager, which you can find in the Start menu (I assume, having never used W10). I know next to nothing about knitr, but if you need that, you probably know more about it than I do. – Torbjørn T. Jun 14 '17 at 17:31
1

I had the same problem. In my case the miktex program folder was not in lyx's PATH field (Tools-> Preferences->Paths->PATH). I added it there, reconfigured and restarted. After some initial hiccups, it started working. I hope this helps!

1

MiKTeX went through substantial change (in terms of how it internally handles updating its packages) at the end of 2017 and IIRC LyX-223-Bundle unfortunately bundles version of MiKTeX containing bug which will render MiKTeX unusable after update. That could cause the problem you are facing.

Possible solutions:

  1. try to reinstall MiKTeX completely.

  2. there is unofficial win installer of LyX 2.3.0, which tries to sanitize the situation automagically at http://ftp.lyx.de/LyXWinInstaller/LyX2.3.0/ . Note however that it will trigger some MiKTeX updating operations in background so don't use that installer blindly in case you have some working and specific MiKTeX setup on your machine, it could change it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.