I would like to get a script O looking like this:

However, \mathcal O and \mathscr O give , which are slightly different.

This is not the pre-1992 \mathcal O.

  • 1
    Old versions of Computer Modern mathcal was available in old versions of Latin Modern, but the O looks nothing like the one you are showing (the changes were minor, see what happened to the F). Your O is more like a variant of mathscr so you could look at "English Script" fonts on a site like myfonts to see if you find something similar (for example, English 111 is a bit closer). From which book(s) does it come from ? Commented Dec 8, 2011 at 6:00
  • Hartshorne's Algebraic Geometry uses it on page 69. It also appears in an old (pre-TeX) article (I'll try to upload a scan tomorrow) which also has a very exotic script A. Commented Dec 8, 2011 at 6:58
  • 1
    OK, that's the script used on monotype machines which you can see in the books about monotype technology (e.g. Chaundy's The Printing of Mathematics or Monotype's List of Mathematical Characters for 4-line mathematics). I'm not sure it's available as a digital font, though. I'll upload a scan later on for you to see. Fonts called Commercial Script come close, but it's not quite that yet. Commented Dec 8, 2011 at 8:32
  • @YuriDelanghe This questions seems borderline for TeX.sx. As far as I can see, you want a particular font which we have no idea has ever been available as a TeX font. At the very least it would be useful to know the source of your graphic.
    – Joseph Wright
    Commented Dec 8, 2011 at 8:46
  • @JosephWright Yes, I hadn't realized that Hartshorne might be non-TeX. Commented Dec 8, 2011 at 18:14

3 Answers 3


\mathscr{O} from the euler package is thinner than the one from mathrsfs, which you obviously use:



  • Still different than the one above, though... I'm looking for that specific O. Commented Dec 8, 2011 at 3:31
  • 2
    Then scan it, and insert the picture. Unless you can provide us some insight as to which font this is, there is not much we can do. Commented Dec 8, 2011 at 10:22

Run with xelatex:

\setmathfont{STIX Math}
\Huge $\mscrO$

enter image description here

amsmath is not needed here but it is always a good idea to load it and that must be done before unicode-math


I had the same problem you had trying to get some equations out of Laeqed that uses TeX so I guess is the same.

In my case I discovered that the font by default was set to be Times New Roman, so I tried to change the font back to the standard one and when i compiled again the problem solved by itself and the $\mathscr{O}$ changed back to $\mathcal{O}$.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .