I just installed WinEdt build: 20170413 (v. 10.2) on Windows 10. the main menu item TeX is missing; also in the Execution Modes config, there are no tabs of either Tex System or Tex Options. Can someone help?

(I installed the same build on Windows 7 earlier, all fine; also to add, I installed MikTex 2.9 before WinEdt install)

  • Welcome to TeX.SX! A TeX distribution like MiKTeX or TeX Live is installed? Jun 16 '17 at 2:28
  • Yes I installed MikTex 2.9 before installing WinEdt, all looks fine for that.
    – Charles Yu
    Jun 16 '17 at 3:15
  • compared with my other install on win7. They have in common those: File,Edit,Search,Insert,Document,Project,View,Tools,Macros,Accessaries,Options,Windows,Help. Also under menu item Insert in my Windows10 install, there was only two items:insert file and date, to my surprise
    – Charles Yu
    Jun 16 '17 at 3:34

Short answer

There can be an only reason to have WinEdt not showing its "TeX" menu without manual customizations: you have accidentally switched configuration...

To overcome this problem, go to "Options" -> "Configurations" menu and click "Default (Auto-Detect)". Everything will be back again.

A little explanation

WinEdt can be used for different purposes other than TeX editing.

Excerpt from the documentation:

WinEdt is used as a front-end for compilers and typesetting systems, such as TeX, HTML or NSIS.

From the "Options" -> "Configurations" menu you can choose what to use WinEdt for.

enter image description here

Choosing "Default (Auto-Detect)", WinEdt will detect your installed TeX distribution and you can use it for all the mentioned tasks.

  • Thanks a lot, to you and to Heiko Oberdiek, and all others. Your suggestion click "Default (Auto-Detect)" solved the problem cleanly.
    – Charles Yu
    Jun 16 '17 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.