0

I'm using the kotex package in order to write in Korean in MikTex, and I found out that an error occurs on certain letters.

\documentclass{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{newtxtext}
\usepackage[nonewtxmathopt]{newtxmath}
\usepackage{kotex}

\begin{document}

\section{가}
나
\begin{enumerate}
\item ㄷ
\end{enumerate}

\end{document} 

The error message is

Couldn't open `uwmj.cfg'

No creation rule for font uwmj31. ! Font

LUC/uhcmj/m/n/10.95/31=uwmj31 at 10.95pt not loadable: Metric (TFM) file not found.

The log is full of 'No creation rule for font uwmj31.', 'No creation rule for font NanumMyeongjo.' etc.

The error only occurs when it faces a single letter; in this case, 'ㄷ' is the cause. The location of the letter doesn't matter. I tried searching for uwmj31 and downloading it but I don't know where I can find it, and I don't know the manual installation procedure either. The problem occuring here seems to be similar to the one in here, but I'm not 100% sure about it.

I've always had a similar problem, and now I decided it's time to learn how to solve this. It seems like MikTex has some bugs related to CJk fonts, and one solution would be just discarding MikTex and using TexLive, but I wish I can keep using MikTex for now.

  • 1
    I haven't the time yet to check, but try the install the files from the uhc-package: mirrors.ctan.org/systems/texlive/tlnet/archive/uhc.tar.xz – Ulrike Fischer Jun 16 '17 at 11:47
  • @UlrikeFischer Sorry, but could you tell me how to install it? I searched for manual installation and found tex.stackexchange.com/questions/2063/… but it doesn't seem to fit in any category listed there. – Taxxi Jun 16 '17 at 11:57
  • It just looked like a normal compressed file so I just copied & pasted the contents into MikTex directory, but the result is the same. Not sure if I have to do configure something. – Taxxi Jun 16 '17 at 12:09
  • Don't put local things in the main miktex tree. Create your own texmf-tree and add it as a local root with miktex settings. – Ulrike Fischer Jun 16 '17 at 12:51
  • 1
    I just tried: unpack the uhc.tar.xz somewhere outside miktex, e.g.in a folder uhc. Then add the root folder as new root in miktex settings (the fonts folder should be the first subfolder). Add \pdfmapfile{=umj.map} to your document or add the map via updmap. – Ulrike Fischer Jun 16 '17 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.