0

This Question is probably related to that one: Error output in biblatex

I'm just moving to TexPad, because I want to use LaTex also on my iPad Pro. I have a lot of (partly really old) LaTeX Sources and had a few problems with character encodings - these are fixed now and I'm using UTF8.

I have a file that compiled normally as long as I did not use my bibliography. Now I added

\usepackage[backend=biber]{biblatex}  
\addbibresource{../Bibliographie_mg.bib} 

...d I'm getting error messages that I do not understand:

enter image description here

I seems to me as if the bib latex package is missing something. Can anyone give me a hint how to fix this? By the way, besides the error messages the file compiles normally, including the bibliography.

So, here a MWE (sorry for the delay I´m on some business trips frequently and there have not the time to face this problem)...

This structure is the one I use most frequently

    \documentclass[11pt, german, a4paper]{article}
%
% Language specific stuff
%
\usepackage{german}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
%
% global stuff
%
\usepackage[official,right]{eurosym}
\usepackage{babel}
\usepackage{a4}
\usepackage{times}
%
% Document specific stuff
%
\usepackage[backend=biber]{biblatex}  
\addbibresource{../Bibliographie_mg.bib} 
%
\begin{document}
This is a citation\cite{Fawcett2003}

\pagebreak
\printbibliography


\end{document}
  • Can you get the proper .log and .blg files? What do the errors say exactly? Can you give us an MWE? – moewe Jun 17 '17 at 15:40
  • Any news here? Without a more detailed error message (.log and .blg) and the document that causes these errors your question is nearly impossible to answer. The screenshot does not even show which command is undefined. – moewe Jun 19 '17 at 10:26
  • @moewe: I just added a MWE. This compiles "normally" but shows the mentioned error messages.... – mgamer Jun 20 '17 at 20:38
1

You should not load \usepackage{german} and \usepackage{babel} at the same time. (See here, I did not find a better reference, but it came from Ulrike, so it is definitely trustworthy.)

biblatex will only pick up your language with babel, so you should simply stop loading

\usepackage{german}

babel alone will suffice.

Note that german turns on the 'alte Rechtschreibung' and ngerman is 'neue Rechtschreibung'.

  • Great! Trank you.... Problem solved and learned something :-) – mgamer Jun 22 '17 at 15:38
0

It's a really old post. I'm not sure anyone still encountered the problem.

I had a similar issue on the Texpad macOS. But I found the declaration of the biblatex package is unnecessary.

When I simply deleted the \usepackage{bibletax}, everything worked well.

  • 1
    Welcome to TeX.SE! Have you tested that? I do not think that is a real solution. Can you show a complete compilable Tex code and its result in an screenshot? – Mensch Aug 21 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.