8

I found that with enquote in the csquotes package, the closing double quote is too close to the last letter:

\documentclass{article}
\usepackage{csquotes}
\begin{document}
\noindent
\enquote{nature of}\\
``nature of''
\end{document}

enter image description here

Is this a known bug (which I don't have to report)? I use pdflatex in texlive 2016.

1
  • Thanks! If csquotes doesn't work correctly without fontenc, it should issue at least a warning, I suppose. Should I ask the creator of the package to consider it as an enhancement? (I prefer enquote to manual quotes because it handles nested quotes automatically.)
    – Ryo
    Jun 19, 2017 at 7:07

3 Answers 3

13

It is not csquotes fault, it is a problem in the OT1-fonts: The kerning is missing if the quote symbol is entered directly and not through a ligature:

\documentclass{article}

\begin{document}

of''
of\char"22
of\textquotedblright


\fontencoding{T1}\selectfont
of''
of\char"11
of\textquotedblright
\end{document}

enter image description here

So this is another reason not to use OT1-encoding -- at least if you want to use the computer modern fonts (the lmodern fonts e.g. don't have this problem).

1
  • Thanks for your comments! Your and egreg's answers indicate that ot1enc.def has to be fixed. My next question then is why it's not done and why T1 is not default---If, on the other hand, there are valid reasons for OT1 to remain unfixed and default, then there should be warnings when some packages are broken under OT1. It's like internal feud :-) The csquotes camp blames OT1 and the OT1 camp blames csquotes and the uniformed (me) is confused :-)
    – Ryo
    Jun 19, 2017 at 12:39
7

You can fix what ot1enc.def does (which is, in my opinion, wrong):

\documentclass{article}
\usepackage{csquotes}

% ot1enc.def has
%\DeclareTextSymbol{\textquotedblright}{OT1}{`\"}
% fix it
\DeclareTextCommand{\textquotedblright}{OT1}{''}

\begin{document}

\noindent
\enquote{nature of}\\
``nature of''
\end{document}

enter image description here

0

Just load fontenc with the T1 option (before inputenc in case you use it [compare]).

\documentclass{article}
\usepackage[T1]{fontenc}
%\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\begin{document}
  \noindent
  \enquote{nature of}\\
  ``nature of''
\end{document}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .