0

I've tried to install beamer on mac using tlmgr, but it asked me to update tlmgr, so I did it. Now when I try to install a package it complains saying that wget is not installed (and it is not, I'm on mac, but it was fine before the update). Any suggestion to fix this mess? (Other than installing wget)

Here is the output:

$ tlmgr install beamer
tlmgr: package repository 
http://ctan.mirror.garr.it/mirrors/CTAN/systems/texlive/tlnet (not verified: gnupg not available)
tlmgr itself needs to be updated.
Please do this via either
  tlmgr update --self
or by getting the latest updater for Unix-ish systems:
  http://mirror.ctan.org/systems/texlive/tlnet/update-tlmgr-latest.sh
and/or Windows systems:
  http://mirror.ctan.org/systems/texlive/tlnet/update-tlmgr-latest.exe
Then continue with other updates as usual.

tlmgr: Terminating; please see warning above!
$ tlmgr update --self
tlmgr: package repository 
http://ctan.mirror.garr.it/mirrors/CTAN/systems/texlive/tlnet (not verified: gnupg not available)
tlmgr: saving backups to /usr/local/texlive/2016basic/tlpkg/backups
[1/2, ??:??/??:??] update: texlive.infra [197k] (41476 -> 44462) ... done
[2/2, 00:01/00:02] update: texlive.infra.x86_64-darwin [277k] (40402 -> 43815) ... done
tlmgr: package log updated: /usr/local/texlive/2016basic/texmf-var/web2c/tlmgr.log
running mktexlsr ...
done running mktexlsr.
$ tlmgr install beamer
/Library/TeX/texbin/tlmgr: Initialization failed (in setup_unix_one):
/Library/TeX/texbin/tlmgr: could not find a usable wget.
/Library/TeX/texbin/tlmgr: Please install wget and try again.
/Library/TeX/texbin/tlmgr: Initialization failed (in setup_unix_one):
/Library/TeX/texbin/tlmgr: could not find a usable xzdec.
/Library/TeX/texbin/tlmgr: Please install xzdec and try again.
tlmgr: Couldn't set up the necessary programs.
Installation of packages is not supported.
Please report to texlive@tug.org.
Use of uninitialized value $r in split at /Library/TeX/texbin/tlmgr line 3980.
tlmgr: Cannot find main repository, you have to tag one as main!
  • Not a direct answer, but updating using the TeX Live Utility GUI installed with MacTeX works without a hitch. Also, wget is a fallback to what it usually does. – Alan Munn Jun 21 '17 at 18:15
  • Furthermore, you're trying to install 2016 packages using the current year repository. This won't work. – Alan Munn Jun 21 '17 at 18:21
  • I'm using BasicTeX – Sirion Jun 21 '17 at 18:21
  • @AlanMunn Furthermore, you're trying to install 2016 packages using the current year repository. This won't work. Could you explain? I'm not an expert at all. Thank you. – Sirion Jun 21 '17 at 18:23
  • TeX Live is updated each year, and the default repository is set to the current year. So you can't update from the default repository once the newest year's distribution is out. There are two solutions: install the current year (I would recommend the full distribution and not BasicTeX, see Do I HAVE to re-install all self-installed packages when TeXLive/MacTeX update yearly? for reasons) or tell tlmgr to use a historic repository. See How to install a package from an older version of TeXLive? . – Alan Munn Jun 21 '17 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.